Bug 592143 - BIND defaults to "_default" as a directory instead of "/var/named"
Summary: BIND defaults to "_default" as a directory instead of "/var/named"
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bind   
(Show other bugs)
Version: 5.5
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Adam Tkac
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 00:25 UTC by Jason Lawer
Modified: 2013-04-30 23:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-17 15:04:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Lawer 2010-05-14 00:25:37 UTC
Description of problem:

bind does not default to /var/named when no directory is specified, instead defaulting to _default

Version-Release number of selected component (if applicable):

bind-9.3.6-4.P1.el5_4.2

How reproducible:

Everytime

Steps to Reproduce:
1. Edit a valid named.conf file 
2. comment out the directory line in the options section
3. start bind and it will fail
  
Actual results:

[akula@jasonlawer ~]$ sudo /etc/init.d/named start
[sudo] password for akula: 
Starting named: 
Error in named configuration:
zone localdomain/IN: loading master file localdomain.zone: file not found
_default/localdomain./IN: file not found
zone localhost/IN: loading master file localhost.zone: file not found
_default/localhost./IN: file not found
zone 0.0.127.in-addr.arpa/IN: loading master file named.local: file not found
_default/0.0.127.in-addr.arpa./IN: file not found
zone 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loading master file named.ip6.local: file not found
_default/0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa./IN: file not found
zone 255.in-addr.arpa/IN: loading master file named.broadcast: file not found
_default/255.in-addr.arpa./IN: file not found
zone 0.in-addr.arpa/IN: loading master file named.zero: file not found
_default/0.in-addr.arpa./IN: file not found
                                                           [FAILED]

Bind fails to start due to files not being found

Expected results:

Bind defaults to /var/named and runs 

Additional info:

Was a client issue, but worked around.

Comment 1 Adam Tkac 2010-05-17 15:04:20 UTC
This is a valid and expected behavior. Check /usr/share/doc/bind-9.3.6/arm/Bv9ARM.pdf (BIND 9 Administrator Reference Manual), section 6.2.16, description of the "directory" directive, please:

...
directory:

The working directory of the server. Any non-absolute pathnames in the configuration file will be taken as relative to this directory. The default location for most server output files (e.g. named.run) is this directory. If a directory is not specified, the working directory defaults to `.', the directory from which the server was started. The directory specified should be an absolute path.
...

Closing as notabug.


Note You need to log in before you can comment on or make changes to this bug.