Bug 592147 - Please add SCST, similar to scsi-target-utils, to RHEL 6
Please add SCST, similar to scsi-target-utils, to RHEL 6
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: RHEL Product and Program Management
Brock Organ
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 20:41 EDT by Justin Clift
Modified: 2011-08-02 15:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-02 15:19:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Clift 2010-05-13 20:41:24 EDT
Description of problem:

RHEL 5 & 6 don't presently include SCST, a popular SCSI target mode driver that provides enhanced functionality over tgt (packaged in RHEL as scsi-target-utils).

It would be good if RHEL 6 could include SCST.  Some of SCST's good features:

  + the code is mature and has a substantial active community of developers,
    users, and contributors expanding it's features and capabilities.

    This shows some of the better known brands in the SCST Community:

    http://scst.sourceforge.net/users.html

  + it makes available additional target modes that scsi-target-utils doesn't
    provide (SRP is one example)

  + it's designed for higher bandwidth hardware (ie. Infiniband and 10GbE),
    giving it lower latency and higher throughput than tgt/scsi-target-utils

  + compiles and runs fine on RHEL 6 (tested on the latest RHEL 6 beta).

This may need to be considered for RHEL 6.1 rather than 6.0, as I think we've missed the cut off date for 6.0.
Comment 2 Mike Christie 2010-05-13 20:57:47 EDT
It is too late for 6.0.

I agree scst and other approaches like LIO and are better than tgt, but none are upstream.

I will add whichever target layer stuff goes upstream. I do not care if it is SCST or LIO or my grandma's target mode layer and drivers.

Just tell Vlad or Nick to get one upstream and we can merge it.
Comment 5 RHEL Product and Program Management 2010-05-13 22:38:49 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 8 Stanislaw Gruszka 2010-10-30 06:21:56 EDT
(In reply to comment #2)

> I will add whichever target layer stuff goes upstream. I do not care if it is
> SCST or LIO or my grandma's target mode layer and drivers.

I think you should care about what you will be supporting :-)

There are rumors that TCM will be merged (quote from bug 638007), IMHO that would be bad decision. I'm ex SCST contributor so my opinion can be  biased somehow, but anyway SCST looks better for me. It's smaller but have more features, it have more users and developers, contributors include Emulex, IBM, Marvell, Mellanox ... vs almost one man effort what seems to be TCM. Of course SCST is far away from being perfect (ideal IMHO would be develop/redesign STGT to make it achieve needed features and performance, however there is no community wanted to do this) but comparing to TCM seems to be better.

There is current thread about that: http://marc.info/?t=128214549600008&r=6&w=2 , most people vote for SCST (including Chetan Loke from Emulex), I think RH should also lobby for inclusion SCST ...
Comment 11 RHEL Product and Program Management 2010-11-30 13:34:52 EST
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.
Comment 13 RHEL Product and Program Management 2011-07-05 19:42:55 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 15 Sayan Saha 2011-08-02 15:19:10 EDT
Closing this BZ request as the upstream Linux kernel community has settled on LIO as the iSCSI target of choice. RHEL 6 currently supports tgt. RHEL will also include LIO support eventually. Other targets (like SCST) won't be considered for inclusion.

Note You need to log in before you can comment on or make changes to this bug.