Bug 592148 - RFE: Integrate with Calendar
RFE: Integrate with Calendar
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: planner (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 20:45 EDT by David Le Sage
Modified: 2010-12-17 16:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-17 16:08:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of Dialogue Box to Populate from Planner When Tasks added to Calendar (49.06 KB, image/png)
2010-05-13 21:07 EDT, David Le Sage
no flags Details

  None (edit)
Description David Le Sage 2010-05-13 20:45:18 EDT
Description of problem:

A user has requested greater integration between GNOME Planner and Evolution's calendar functionality. The user requests that the tasks for each day should automatically populate the calendar so the user can see, at a glance, the tasks upon which they should be acting.

I am not sure how this feature would be implemented.  I imagine that, when new people resources are added, the email address will need to be supplied and that when the task dates and people are assigned, their tasks would need to be sent out to each of them as calendar population items.  

Please investigate the feasibility of incorporating this functionality as it would be a powerful feature and lead to greater integration between GNOME applications.

Version-Release number of selected component (if applicable):
Planner 0.14.4

Steps to Reproduce:
1. When tasks are created and resources assigned, Planner should populate Evolution's calendar.

Actual results:
Functionality does not exist at present.

Expected results:
User should be able to go into Evoltion calendar view and be able to see which tasks they need to be doing that day.

Additional info:
Comment 1 David Le Sage 2010-05-13 21:06:22 EDT
Evolution currently supplies an option to populate task details as well.  See:

File->New->Task

then, from the dialogue box that presents itself:

Options->Status Details.


If these details could be populated/updated from Planner as well, that would be great. That way, percentage completed, etc, could be imported into Evolution as soon as it is updated.
Comment 2 David Le Sage 2010-05-13 21:07:06 EDT
Created attachment 413927 [details]
Screenshot of Dialogue Box to Populate from Planner When Tasks added to Calendar
Comment 3 Caolan McNamara 2010-05-14 03:48:18 EDT
I'm not entirely sure what you want. There is a planner-eds package which purports to provide a certain degree of interoperability between evolution and planner. I'm not entirely sure how useful that currently is or if it provides any of the desired functionality but it might be worth a look to see if it does anything helpful.
Comment 4 David Le Sage 2010-05-16 18:39:31 EDT
Hello Caolan,


I have passed this info on to the person requesting the functionality.  I've told them to give us feedback on whether it meets their needs.


Thanks and cheers.
Comment 5 David Le Sage 2010-05-26 02:17:49 EDT
Hello Caolan,

I haven't heard back from the person who requested the feature but I have been trying it myself.  It seems to be only partially working.

It will load names of resources from Evolution but not pre-booked dates nor is there an export function.

Trying it with Zimbra seems to make it hang.  It tries to search but never makes any progress.
Comment 6 Caolan McNamara 2010-12-17 16:08:02 EST
Have to be honest here, there's next to no chance I'll be able to get around to this. Might have better luck reporting this directly to planner's upstream bugzilla.

Note You need to log in before you can comment on or make changes to this bug.