Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 592179 - "yum update" hangs on "Running Transaction Test"
"yum update" hangs on "Running Transaction Test"
Status: CLOSED DUPLICATE of bug 547548
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-14 03:08 EDT by Frode Tennebø
Modified: 2014-01-21 18:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-14 03:42:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frode Tennebø 2010-05-14 03:08:35 EDT
Description of problem:

> yum update
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: redhat.linux.ee
 * updates: redhat.linux.ee
Setting up Update Process
Resolving Dependencies
--> Running transaction check
:
:
Running rpm_check_debug
Running Transaction Test

[hangs indefinitely]

Version-Release number of selected component (if applicable):

[root@luke rpm]# rpm -q yum
yum-3.2.27-3.fc12.noarch

How reproducible:

Every time - if an NFS mount hangs.

Steps to Reproduce:
1. Make sure than an NFS mount hangs, typically by killing the NFS server/service
2. yum update on the NFS client
3.
  
Actual results:

yum hangs.

Expected results:

yum does not hang.

Additional info:

This has probably been an issue since FC8:

http://linux.derkeiler.com/Mailing-Lists/Fedora/2008-01/msg02236.html
Comment 1 Panu Matilainen 2010-05-14 03:42:48 EDT
This been an issue as long as rpm has existed. Mount points which a given transaction doesn't touch are no longer accessed by rpm in F13 and beyond, so unrelated stale mounts no longer cause hangups. The fix is not suitable for backporting to rpm 4.7.x in F12 though.

*** This bug has been marked as a duplicate of bug 547548 ***

Note You need to log in before you can comment on or make changes to this bug.