Bug 592253 - SELinux is preventing /usr/bin/qemu-kvm "read" access on ubuntu-10.04-dvd-i386.iso.
SELinux is preventing /usr/bin/qemu-kvm "read" access on ubuntu-10.04-dv...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:af0d0e09fb3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-14 07:21 EDT by Aaron
Modified: 2010-05-17 10:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-17 10:24:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron 2010-05-14 07:21:57 EDT
Summary:

SELinux is preventing /usr/bin/qemu-kvm "read" access on
ubuntu-10.04-dvd-i386.iso.

Detailed Description:

SELinux denied access requested by qemu-kvm. It is not expected that this access
is required by qemu-kvm and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:svirt_t:s0:c281,c892
Target Context                unconfined_u:object_r:default_t:s0
Target Objects                ubuntu-10.04-dvd-i386.iso [ lnk_file ]
Source                        qemu-kvm
Source Path                   /usr/bin/qemu-kvm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           qemu-system-x86-0.11.0-13.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.11-99.fc12.x86_64 #1
                              SMP Mon Apr 5 19:59:38 UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Fri 14 May 2010 09:18:24 PM EST
Last Seen                     Fri 14 May 2010 09:18:24 PM EST
Local ID                      62613f94-ca1f-4011-9e13-bf445138810c
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1273835904.975:28): avc:  denied  { read } for  pid=10723 comm="qemu-kvm" name="ubuntu-10.04-dvd-i386.iso" dev=sdb1 ino=395516 scontext=system_u:system_r:svirt_t:s0:c281,c892 tcontext=unconfined_u:object_r:default_t:s0 tclass=lnk_file

node=(removed) type=SYSCALL msg=audit(1273835904.975:28): arch=c000003e syscall=2 success=no exit=-13 a0=7fffa0417600 a1=1000 a2=1a4 a3=30 items=0 ppid=1 pid=10723 auid=4294967295 uid=107 gid=107 euid=107 suid=107 fsuid=107 egid=107 sgid=107 fsgid=107 tty=(none) ses=4294967295 comm="qemu-kvm" exe="/usr/bin/qemu-kvm" subj=system_u:system_r:svirt_t:s0:c281,c892 key=(null)



Hash String generated from  catchall,qemu-kvm,svirt_t,default_t,lnk_file,read
audit2allow suggests:

#============= svirt_t ==============
allow svirt_t default_t:lnk_file read;
Comment 1 Daniel Walsh 2010-05-14 09:27:07 EDT
Did you setup some kind of link in /?

Or within your own directory under /?
Comment 2 Aaron 2010-05-14 09:42:42 EDT
I had a symbolic link ~/Downloads/DISTROS/UBUNTU/ubuntu-10.04-dvd-i386.iso pointing to ~/Downloads/ubuntu-10.04-dvd-i386.iso

Is the expected behaviour of SELinux to deny access in such a case?
Comment 3 Daniel Walsh 2010-05-14 10:19:11 EDT
No but it looks like you have a labeling problem.

restorecon -R -v /home
Comment 4 Aaron 2010-05-15 04:03:50 EDT
Seems to have worked, thanks!

Note You need to log in before you can comment on or make changes to this bug.