Bug 592314 - [RFE?] rhncfg-manager not invokable with --password and --username
Summary: [RFE?] rhncfg-manager not invokable with --password and --username
Keywords:
Status: CLOSED DUPLICATE of bug 918036
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Configuration Management
Version: 541
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2010-05-14 14:33 UTC by Jiri Kastner
Modified: 2018-12-03 17:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-15 11:24:25 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jiri Kastner 2010-05-14 14:33:22 UTC
Description of problem:
we are not able to automate tasks without using 'expect'. rhnreg_ks has possibility to enter password using its own option, it would be nice to have such possibility in other rhn tools.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. install rhncfg-management
2. run rhncfg-manager list-channels --username=some_username_here --password=very_secret_password_here
3. check results
  
Actual results:
# rhncfg-manager list-channels --username=some_username_here --password=very_secret_password_here
Usage: rhncfg-manager list-channels

rhncfg-manager: error: no such option: --username

# rhncfg-manager list-channels --password=very_secret_password_here
Usage: rhncfg-manager list-channels

rhncfg-manager: error: no such option: --password

Expected results:
# rhncfg-manager list-channels --username=some_username_here --password=very_secret_password_here
Available config channels:
# echo $?
0

Additional info:

Comment 1 Jan Hutař 2010-05-19 11:37:25 UTC
Note this is to automate RHN Proxy installation easily.

This might be only some config file variable. Same as user name is.

Comment 5 Jan Pazdziora 2013-03-15 11:24:25 UTC
Marking as dupe of 918036 which has proposed patch attached to it.

*** This bug has been marked as a duplicate of bug 918036 ***


Note You need to log in before you can comment on or make changes to this bug.