Bug 592355 - minicom unable to use unix domain socket file as modem
minicom unable to use unix domain socket file as modem
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: minicom (Show other bugs)
14
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Görig
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 765659
  Show dependency treegraph
 
Reported: 2010-05-14 11:58 EDT by David Shea
Modified: 2011-12-08 22:34 EST (History)
1 user (show)

See Also:
Fixed In Version: minicom-2.4-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 765659 (view as bug list)
Environment:
Last Closed: 2010-09-30 02:20:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Shea 2010-05-14 11:58:57 EDT
Description of problem:

minicom allows the use of a unix socket file by specifying the serial device as "unix#<path to socket file>".  This does not currently work due to the changes applied to open_term in main.c by the minicom-2.4-rh.patch.  The added code to perform a ttylock on the modem file does not check for the socket prefix, the attempt to lock fails and minicom exits.

Version-Release number of selected component (if applicable):
minicom-2.4-1.fc14.i686

How reproducible:
Always

Steps to Reproduce:
1. Configure minicom to use a unix socket as the Serial Device setting
2. Attempt to connect
  
Actual results:
Exits with status 1, prints to stderr:
"Device unix#/home/dshea/modem access failed: No such file or directory."


Expected results:
Connect to the socket file

Additional info:
Comment 1 Bug Zapper 2010-07-30 07:37:46 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Fedora Admin XMLRPC Client 2010-09-08 08:11:50 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Jan Görig 2010-09-17 06:49:17 EDT
Thank you for your bug report. I have updated patch so locking is not performed on UNIX sockets now.
Comment 4 Fedora Update System 2010-09-17 06:53:46 EDT
minicom-2.4-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/minicom-2.4-2.fc14
Comment 5 Fedora Update System 2010-09-20 14:43:31 EDT
minicom-2.4-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update minicom'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/minicom-2.4-2.fc14
Comment 6 Fedora Update System 2010-09-30 02:20:08 EDT
minicom-2.4-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.