Bug 592394 - i7core_edac driver does not have Westmere support
Summary: i7core_edac driver does not have Westmere support
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel   
(Show other bugs)
Version: 1.2
Hardware: x86_64
OS: All
low
high
Target Milestone: ---
: ---
Assignee: Luis Claudio R. Goncalves
QA Contact: David Sommerseth
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 18:50 UTC by IBM Bug Proxy
Modified: 2016-05-22 23:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-12 19:23:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch set that adds Westmere support (13.69 KB, application/octet-stream)
2010-05-14 18:50 UTC, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 63724 None None None Never

Description IBM Bug Proxy 2010-05-14 18:50:38 UTC
-- Problem description --
The current i7core_edac driver in the MRG 1.2 kernel does not have support for Westmere processors.
 We need this for several of our newer platforms.

A patch set that adds Westmere support

This patchset adds Westmere support as well as bringing it up to date with the current linux-next.

It has four patches:
1) patch to bring the i7core_edac driver up to date with linux-next
2) patch to fix a bug that prevents ECC errors from getting reported
3) patch to fix a bug in the probe path
4) patch to add Westmere support

The patchset was built against the kernel-rt-2.6.24.7-152.el5rt.src.rpm source.  Please apply!

Comment 1 IBM Bug Proxy 2010-05-14 18:50:42 UTC
Created attachment 414130 [details]
A patch set that adds Westmere support

Comment 2 IBM Bug Proxy 2010-11-01 23:11:19 UTC
------- Comment From vernux@us.ibm.com 2010-11-01 19:08 EDT-------
This bug seems to have gotten ignored (on both sides) since it was opened.  Are there any more plans for MRG 1.2 errata kernels?  If so, could we please get this patchset included?

Comment 3 Clark Williams 2010-11-02 13:58:16 UTC
We have no plans to update the 2.6.24 -rt series with further errata. Does this patchset exist in the 2.6.33 series?

Comment 4 IBM Bug Proxy 2010-11-02 14:41:02 UTC
------- Comment From vernux@us.ibm.com 2010-11-02 10:37 EDT-------
MRG 1.3 already has the patches.  I am just kicking myself for dropping the ball on this one for MRG 1.2.


Note You need to log in before you can comment on or make changes to this bug.