Bug 592407 - [RHEL 6] Thunderbird displaying incorrect number of unread messages
Summary: [RHEL 6] Thunderbird displaying incorrect number of unread messages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: thunderbird
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Red Hat Gecko Maintainer
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 19:32 UTC by Alan Matsuoka
Modified: 2018-10-27 15:19 UTC (History)
6 users (show)

Fixed In Version: thunderbird-3.0.4-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-02 20:54:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
tbird-2.0.0.22.png (4.16 KB, image/png)
2010-05-14 19:34 UTC, Alan Matsuoka
no flags Details
tbird-3.0.png (5.40 KB, image/png)
2010-05-14 19:35 UTC, Alan Matsuoka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Mozilla Foundation 540554 0 None None None Never

Description Alan Matsuoka 2010-05-14 19:32:46 UTC
Problem Description
---------------------------------------------------
1. Time and date of problem:

05-12-2010 09:45pm EDT

2. System architecture(s):

x86_64

3. Provide a clear and concise problem description as it is understood at the time of escalation. Please be as specific as possible in your description. Do not use the generic term "hang", as that can mean many things.
  Observed behavior:

Thunderbird 3.0 appears to be displaying the number of unread messages in a folder incorrectly.

In Thunderbird 2.0.0.22 on RHEL5, the customer see's 1659 unread messages, but on RHEL6 and Thunderbird 3.0, they are seeing 201 unread messages listed.  

Screen shots of 2.0.0.22 and 3.0 are attached.  

  Desired behavior:

For Thunderbird in RHEL 6 to correctly display the number of unread messages.  

4. Specific action requested of SEG:

Can you please open a RH BZ about the observed behavior?  

5. Is a defect (bug) in the product suspected? yes/no
  Bugzilla number (if one already exists):

A defect is suspected.  It looks like this was reported upstream:
https://bugzilla.mozilla.org/show_bug.cgi?id=543224

6. Does a proposed patch exist? yes/no
  If yes, attach patch, making sure it is in unified diff format (diff -pruN)

Not that I am aware of.  

7. What is the impact to the customer when they experience this problem? This is especially important for severity one and two issues:

Thunderbird 3.0 is not working as expected in RHEL 6.

Looks like this was reported upstream:
https://bugzilla.mozilla.org/show_bug.cgi?id=543224

Customer is seeing symptoms from
https://bugzilla.mozilla.org/show_bug.cgi?id=540554 as well.  543224 is
a dupe of 540554.



Issue escalated to Support Engineering Group by: spurrier.

Comment 1 Alan Matsuoka 2010-05-14 19:34:53 UTC
Created attachment 414142 [details]
tbird-2.0.0.22.png

Comment 2 Alan Matsuoka 2010-05-14 19:35:15 UTC
Created attachment 414143 [details]
tbird-3.0.png

Comment 3 Matěj Cepl 2010-05-17 23:45:35 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Could you please switch on logging of IMAP (are we talking about IMAP account, right?) per https://wiki.mozilla.org/MailNews:Logging and attach IMAP log from brief session (long enough just to demonstrate the problem) to the bug report as individual uncompressed file attachment using the bugzilla file attachment link above?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 6 Christopher Aillon 2010-06-04 23:07:53 UTC
Thunderbird has already been rebased in the RHEL 6 trees.  It's currently at thunderbird-3.0.4, which should resolve this issue.

Comment 10 Tomas Pelka 2010-06-23 12:14:00 UTC
Can't reproduce this issue on my thunderbird-3.0.4-3.el6.x86_64. The numbers of readed/unreaded messages are correct for me. 

Moving to verified.

Comment 11 releng-rhel@redhat.com 2010-07-02 20:54:10 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.