Bug 592417 - ENOPERM when reading /proc/sys/vm/mmap_min_addr
Summary: ENOPERM when reading /proc/sys/vm/mmap_min_addr
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 6.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Eric Paris
QA Contact: Qian Cai
URL:
Whiteboard:
Keywords:
Depends On: 583292
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 20:00 UTC by Eric Paris
Modified: 2010-11-10 20:54 UTC (History)
11 users (show)

Fixed In Version: kernel-2.6.32-28.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 583292
Environment:
Last Closed: 2010-11-10 20:54:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Paris 2010-05-14 20:00:51 UTC
+++ This bug was initially created as a clone of Bug #583292 +++

Description of problem:
Despite the permissions showing global read access, /proc/sys/vm/mmap_min_addr can not be read by normal users.


Version-Release number of selected component (if applicable):
2.6.32.11-99 is where I see the issue
2.6.32.11-90 works fine.

How reproducible:
100%

Steps to Reproduce:
1. Boot using kernel 2.6.32.11-99
2. cat /proc/sys/vm/mmap_min_addr
  
Actual results:
ERROR permission denied

Expected results:
"0" or "4096" or whatever your configuration has.

Additional info:

--- Additional comment from cebbert@redhat.com on 2010-04-21 12:52:51 EDT ---

*** Bug 582810 has been marked as a duplicate of this bug. ***

--- Additional comment from eparis@redhat.com on 2010-05-14 16:00:30 EDT ---

fixed upstream in 2.6.34.  If you need this in an older kernel please reopen this bug and I can backport.

Comment 2 RHEL Product and Program Management 2010-05-17 21:25:43 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Aristeu Rozanski 2010-05-20 21:59:11 UTC
Patch(es) available on kernel-2.6.32-28.el6

Comment 6 Hiroto Shibuya 2010-06-16 17:15:34 UTC
This also regressed in 2.16.18 kernel on RHEL 5 between 2.6.18-164.15 and 2.6.18-194.3 kernel.  Exact same symptom as described here. 

It broke "bitbake" for OpenEmbedded development.

Comment 8 Hiroto Shibuya 2010-08-12 02:50:27 UTC
I cloned the original Bug #583292 to Bug #623519 against RHEL 5.

Comment 9 releng-rhel@redhat.com 2010-11-10 20:54:12 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.