Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 592450 - RHEL5->RHEL6 patch list check (aarcange@redhat.com)
RHEL5->RHEL6 patch list check (aarcange@redhat.com)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Andrea Arcangeli
Virtualization Bugs
:
Depends On:
Blocks: 580953 KvmRhel5to6Patches
  Show dependency treegraph
 
Reported: 2010-05-14 17:34 EDT by Eduardo Habkost
Modified: 2010-07-23 07:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-23 07:37:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduardo Habkost 2010-05-14 17:34:45 EDT
This bug is for the task of checking for RHEL5 KVM patches that are not yet upstream or not included on RHEL6
Comment 2 Eduardo Habkost 2010-05-14 17:56:04 EDT
Sorry for the Bugzilla spam on virt-maint. Removing virt-maint from CC/assignee.
Comment 4 RHEL Product and Program Management 2010-06-07 11:57:55 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 8 RHEL Product and Program Management 2010-07-15 10:13:35 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 9 Andrea Arcangeli 2010-07-21 11:59:45 EDT
This patch http://harpoon.virt.bos.redhat.com/~ehabkost/kvm-patches/kvm-0006-avoid-cancelling-ide-dma.patch I think shall be ported to rhel6 and I posted it to rhvirt-patches with Message-ID: <20100721152112.GZ24928@random.random>


I'm uncertain about:

http://harpoon.virt.bos.redhat.com/~ehabkost/kvm-patches/kvm-KSM-suspend-fix.patch

If ksm needs that, khugepaged may need that too.

This patch http://harpoon.virt.bos.redhat.com/~ehabkost/kvm-patches/kvm-enable-sysenter-on-32bit-guests-skype-fix.patch is already being handled in bug 614537

All others are obsolete or upstream.
Comment 10 Andrea Arcangeli 2010-07-22 20:41:59 EDT
Patch kvm-KSM-suspend-fix.patch is obsolete because RHEL6 will not freeze tasks that didn't run set_freezable. However I wonder if set_freezable()+try_to_freeze() is still needed in ksmd and khugepaged to avoid the risk of issuing I/O during suspend to disk if an allocation triggers swapout. Hugh thinks it's not needed but I'm discussing with him about this.

I'll open separate bug for rhvirt-patches with
Message-ID: <20100721152112.GZ24928@random.random>.
Comment 11 Andrea Arcangeli 2010-07-22 22:51:12 EDT
In the end (after noticing kswapd also uses try_to_freeze) I opened bug 617430.

So everything has been forward ported and handled through other bugzillas, this bugzilla can be closed, thanks!
Comment 12 Bill Burns 2010-07-23 07:37:46 EDT
Closed per previous comment.

Note You need to log in before you can comment on or make changes to this bug.