Bug 592490 - Underscores in VM name turn into tray-menu mnemonics
Underscores in VM name turn into tray-menu mnemonics
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-14 18:40 EDT by Josh Stone
Modified: 2010-09-04 00:59 EDT (History)
5 users (show)

See Also:
Fixed In Version: virt-manager-0.8.5-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-04 00:59:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Stone 2010-05-14 18:40:55 EDT
Description of problem:
When the virt-manager system tray icon is enabled, its menu shows each host machine with a submenu of the virtual machines on that host.  The problem is that my VMs are named with underscores, and these get turned into mnemonic markers.  So "vm_f12_32" turns into "vmf1232" with mnemonics on the 'f' and '3'.

Version-Release number of selected component (if applicable):
virt-manager-0.8.3-3.fc13.noarch

Additional info:
I believe underscores can be escaped in GTK labels by doubling up...
Comment 1 Cole Robinson 2010-08-23 11:19:16 EDT
Thanks for the report, fixed upstream now:

http://hg.fedorahosted.org/hg/virt-manager/rev/f5b1d2706f7e
Comment 2 Fedora Update System 2010-08-25 16:59:09 EDT
virt-manager-0.8.5-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13
Comment 3 Fedora Update System 2010-08-25 20:53:33 EDT
virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13
Comment 4 Fedora Update System 2010-08-31 23:27:54 EDT
virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13
Comment 5 Fedora Update System 2010-09-04 00:59:06 EDT
virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.