Bug 592550 - tremulous doesn't run at all.
tremulous doesn't run at all.
Status: CLOSED DUPLICATE of bug 602374
Product: Fedora
Classification: Fedora
Component: tremulous (Show other bugs)
13
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-15 06:37 EDT by Ankur Sinha (FranciscoD)
Modified: 2010-06-10 01:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 01:58:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ankur Sinha (FranciscoD) 2010-05-15 06:37:03 EDT
Description of problem:
I installed tremulous using yum. It won't run.

Setting it to 'urgent' because the game doesn't run at all

Version-Release number of selected component (if applicable):
tremulous-1.1.0-10.fc12.x86_64

How reproducible:
run tremulous. 

Steps to Reproduce:
1.install tremulous using yum
2.run tremulous
3.
  
Actual results:
fails to run

Expected results:
should run normally

Additional info:

This is what I get when I run it from a terminal:

[Ankur@localhost ~]$ tremulous
tremulous 1.1.0 linux-x86_64 Aug 16 2009
----- FS_Startup -----
Current search path:
/home/Ankur/.tremulous/base
/usr/share/tremulous/base/vms-1.1.0.pk3 (4 files)
/usr/share/tremulous/base/map-uncreation-1.1.0.pk3 (110 files)
/usr/share/tremulous/base/map-tremor-1.1.0.pk3 (45 files)
/usr/share/tremulous/base/map-transit-1.1.0.pk3 (135 files)
/usr/share/tremulous/base/map-niveus-1.1.0.pk3 (134 files)
/usr/share/tremulous/base/map-nexus6-1.1.0.pk3 (151 files)
/usr/share/tremulous/base/map-karith-1.1.0.pk3 (118 files)
/usr/share/tremulous/base/map-atcs-1.1.0.pk3 (87 files)
/usr/share/tremulous/base/map-arachnid2-1.1.0.pk3 (67 files)
/usr/share/tremulous/base/data-1.1.0.pk3 (1229 files)
/usr/share/tremulous/base
/usr/bin/base

----------------------
2080 files in pk3 files
execing default.cfg
couldn't exec autogen.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----

------- Input Initialization -------
Joystick is not active.
------------------------------------
...loading libGL.so.1:
Calling SDL_Init(SDL_INIT_VIDEO)...
SDL_Init(SDL_INIT_VIDEO) passed.
Initializing OpenGL display
...setting mode 3: 640 480
Using 8/8/8 Color bits, 24 depth, 8 stencil display.
GL_RENDERER: Gallium 0.4 on NV46
Initializing OpenGL extensions
...GL_S3_s3tc not found
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array

GL_VENDOR: nouveau
GL_RENDERER: Gallium 0.4 on NV46
GL_VERSION: 2.0 Mesa 7.8.1
GL_EXTENSIONS: GL_ARB_copy_buffer GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_coord_conventions GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_imaging GL_ARB_map_buffer_range GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_shading_language_120 GL_ARB_shadow GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_cull_vertex GL_EXT_compiled_vertex_array GL_EXT_convolution GL_EXT_copy_texture GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_fog_coord GL_EXT_histogram GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_3DFX_texture_compression_FXT1 GL_APPLE_client_storage GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ATI_blend_equation_separate GL_ATI_separate_stencil GL_IBM_multimode_draw_arrays GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_texgen_reflection GL_NV_vertex_program GL_NV_vertex_program1_1 GL_OES_read_format GL_SGI_color_matrix GL_SGI_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays
GL_MAX_TEXTURE_SIZE: 4096
GL_MAX_ACTIVE_TEXTURES_ARB: 8

PIXELFORMAT: color(24-bits) Z(24-bit) stencil(8-bits)
MODE: 3, 640 x 480 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
CPU: 
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_LINEAR
picmip: 0
texture bits: 0
multitexture: enabled
compiled vertex arrays: enabled
texenv add: disabled
compressed textures: disabled
Initializing Shaders
...loading 'scripts/uncreation.shader'
...loading 'scripts/q3map2_tremor.shader'
...loading 'scripts/tremor.shader'
...loading 'scripts/transit.shader'
...loading 'scripts/niveus.shader'
...loading 'scripts/nexus6.shader'
...loading 'scripts/karith.shader'
...loading 'scripts/atcs.shader'
...loading 'scripts/arachnid2.shader'
...loading 'scripts/jetpack.shader'
...loading 'scripts/core.shader'
...loading 'scripts/flame.shader'
...loading 'scripts/misc.shader'
...loading 'scripts/common-trem.shader'
...loading 'scripts/titan.shader'
...loading 'scripts/water.shader'
...loading 'scripts/displays.shader'
...loading 'scripts/plant_life.shader'
...loading 'scripts/stasis.shader'
...loading 'scripts/booster.shader'
...loading 'scripts/eggpod.shader'
...loading 'scripts/medistat.shader'
...loading 'scripts/mgturret.shader'
...loading 'scripts/reactor.shader'
...loading 'scripts/telenode.shader'
...loading 'scripts/trapper.shader'
...loading 'scripts/overmind.shader'
...loading 'scripts/tesla.shader'
...loading 'scripts/dcc.shader'
...loading 'scripts/hive.shader'
...loading 'scripts/level2.shader'
...loading 'scripts/human.shader'
...loading 'scripts/null.shader'
...loading 'scripts/weapons.shader'
...loading 'scripts/conkit.shader'
...loading 'scripts/advckit.shader'
...loading 'scripts/psaw.shader'
...loading 'scripts/mdriver.shader'
...loading 'scripts/flamer.shader'
...loading 'scripts/crosshairs.shader'
...loading 'scripts/grenade.shader'
...loading 'scripts/splash.shader'
...loading 'scripts/marks.shader'
...loading 'scripts/sprites.shader'
...loading 'scripts/muzzleflashes.shader'
----- finished R_Init -----
------ Initializing Sound ------
Initializing SDL audio driver...
SDL audio driver is "pulse".
SDL_AudioSpec:
  Format:   AUDIO_S16LSB
  Freq:     22050
  Samples:  256
  Channels: 2
Starting SDL audio callback...
SDL audio initialized.
----- Sound Info -----
    1 stereo
 8192 samples
   16 samplebits
    1 submission_chunk
22050 speed
0x27e2730 dma buffer
No background file.
----------------------
Sound intialization successful.
--------------------------------
Sound memory manager started
Loading vm file vm/ui.qvm...
...which has vmMagic VM_MAGIC_VER2
Loading 1075 jump table targets
compiling ui
running assembler < /tmp/ui.s_HJ3959 > /tmp/ui.o_oHbveN
done
computing jump table
VM file ui compiled to 6261955 bytes of code (0x7f09e0020000 - 0x7f09e0618cc3)
ui loaded in 4596672 bytes on the hunk
^1Error: file ui/joinserver.menu, line 1: file ui/menddef.h not found
^1Error: file ui/punkbuster.menu, line 1: file ui/menddef.h not found
^1Error: file ui/connect.menu, line 1: file ui/menddef.h not found
^1Error: file ui/password.menu, line 1: file ui/menddef.h not found
^1Error: file ui/error.menu, line 1: file ui/menddef.h not found
^1Error: file ui/serverinfo.menu, line 1: file ui/menddef.h not found
^1Error: file ui/findplayer.menu, line 1: file ui/menddef.h not found
^1Error: file ui/quitcredit.menu, line 1: file ui/menddef.h not found
^1Error: file ui/createfavorite.menu, line 1: file ui/menddef.h not found
UI menu load time = 3 milli seconds
^1Error: file ui/ingame.menu, line 1: file ui/menddef.h not found
^1Error: file ui/ingame_options.menu, line 1: file ui/menddef.h not found
UI menu load time = 2 milli seconds
^1Error: file ui/tremulous_humanarmoury.menu, line 1: file ui/menddef.h not found
^1Error: file ui/tremulous_humandialogs.menu, line 1: file ui/menddef.h not found
^1Error: file ui/tremulous_aliendialogs.menu, line 1: file ui/menddef.h not found
^1Error: file ui/tremulous_alienupgrade.menu, line 1: file ui/menddef.h not found
UI menu load time = 1 milli seconds
********************
ERROR: opStack corrupted in compiled code (offset 1692500368)

********************
----- CL_Shutdown -----
Closing SDL audio device...
SDL audio device shut down.
RE_Shutdown( 1 )
----- CL_Shutdown -----
recursive shutdown
Sys_Error: recursive error after: opStack corrupted in compiled code (offset 1692500368)
Comment 1 Rahul Sundaram 2010-06-10 01:58:57 EDT
The other bug report has more history.  I am closing this one against a cloned bug.  The fix appears to be to build a different client altogether like Mandriva has.  I will look into that by the end of the day.  If you are interested, let me know.

*** This bug has been marked as a duplicate of bug 602374 ***

Note You need to log in before you can comment on or make changes to this bug.