Bug 592570 - Hangs in early stages of installation
Summary: Hangs in early stages of installation
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-15 12:53 UTC by Audrius Meskauskas
Modified: 2010-06-18 18:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-18 18:27:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
Contents of /tmp and listing of /dev after Anaconda hang (43.78 KB, application/x-gzip)
2010-05-20 19:58 UTC, Audrius Meskauskas
no flags Details

Description Audrius Meskauskas 2010-05-15 12:53:12 UTC
Description of problem:


Version-Release number of selected component (if applicable):
RHEL Server beta.

How reproducible:
When executed on the physical machine, the installer always hangs in early stages of installation. The exact step where it happens varies: it can be as early as on "waiting devices to intialize" or more often when the first (with logo only) or second  graphical screen comes out, in one case the installation proceeded as far as till next screen after device selection.

In one case I observed the bunch of error messages mentioning aacraid. The problem may be related to Adaptec 5405Z RAID controller that is used in this server. This controller works without any issues with RHEL 5 server edition.

I am not aware which component contributes to the crash, it may or may not be anaconda. The installer maybe should do something else than hanging silently.

The same DVD disk works well when installed into virtual machine on the same server.

Comment 2 Chris Lumens 2010-05-15 14:40:52 UTC
Can you please attach the exact error messages you are seeing?  These are in /tmp/syslog, which you can get to from tty2 when anaconda is running.

Comment 3 Audrius Meskauskas 2010-05-17 06:26:50 UTC
This bug goes away when I use a floppy with the Adaptec drive during installation.

Comment 4 Hans de Goede 2010-05-17 08:55:38 UTC
Hi,

(In reply to comment #3)
> This bug goes away when I use a floppy with the Adaptec drive during
> installation.    

A floppy? Can you be a bit more precise, you mean when you attach a floppy drive
to the system in question / insert a floppy into an already present / ... ?

Please don't leave us guessing things like this, but try to describe what you are doing, what you are seeing as a result and what you would have expected to see in as much detail as possible.

And we would still like that /tmp/syslog file.

Thanks,

Hans

Comment 5 Audrius Meskauskas 2010-05-17 12:50:03 UTC
I have attached the USB floppy containing aacraid driver while I know RHEL should have its own. I attached it before powering the server up so it was present during all booting and installation process. The floppy was active time to time (emitting sounds). With that floppy attached, the installation seems passing further but it hang immediately after message "partitioning changes will be written to the disk" and next time when checking the filesystems (the progress bar was running back and forward for some time when it stopped). 

That do you mean as "tty2" ? Do you want me to connect null modem cable and try to talk using serial console?

Comment 6 Audrius Meskauskas 2010-05-20 06:58:25 UTC
Do you have any startup parameter - switch to force the installation in text and not in GUI mode? Maybe this could help?

Yesterday I tried more attempts with the USB floppy attached. The installer than passes the partitioning screen but reliably hangs when it starts scanning filesystems for consistency. 

Please provide more details or web link on how to get "tty2" access during installation. I never did this before.

Comment 7 Hans de Goede 2010-05-20 07:36:30 UTC
Hi,

Yes we have an startup parameter called "text", note it is better to use "vnc" and then connect to the install with vnc, as text installs are very limited in functionality.

To get to tty2 press ctrl + alt + f2 all together.

When you say you've "attached the USB floppy containing aacraid driver", may I ask how you put the driver on the floppy and where you got this specific driver from ?

Thanks,

Hans

Comment 8 Audrius Meskauskas 2010-05-20 08:24:14 UTC
Adaptec 5405Z was sold together with the driver CD. After I booted from this CD into some kind of specific OS, one of the GUI options was "create a driver floppy". There is no floppy drive on the server (Supermicro 5016-MTFB, single quad core CPU, 24 Gb RAM, four 1 Tb hard drives attached to 5405Z, no other hard drives) so I attached external USB floppy drive and the tool wrote something in it. Deciding from the sound, the floppy driver is active during the installation.

Without floppy drive with this driver disk attached the installation usually hangs on the first screen with company logo only, at times even earlier. With drive it may proceed as far as till checking the filesystems but in some cases also hangs earlier. 

I am not sure how probable is that just the installer is somehow unstable in a complex way that is influenced by the floppy present. Also it may be that we have the combination of the two bugs.

Comment 9 Hans de Goede 2010-05-20 09:13:23 UTC
Can you please collect kernel messages from the system ? For example by having a serial console attached (and passing the console=.... argument for such when starting the installer) and logging the messages being send to the serial port.

Or by doing a vnc install and trying to get /tmp/syslog from tty2, but chances
are the hang is such that even tty2 will no longer function.

Comment 10 Audrius Meskauskas 2010-05-20 19:58:12 UTC
Created attachment 415500 [details]
Contents of /tmp and listing of /dev after Anaconda hang

Switching to console worked and I was able to copy contents of all /tmp folder plus the listing of /dev directory. Hope this will help.

Comment 11 Hans de Goede 2010-05-21 06:23:16 UTC
Hi,

Thanks for the logs, I'm afraid I see nothing special in the logs.

Can yuo try again, and when the installer hangs, switch to tty2 and do:
ps axf > ps.log
And attach ps.log here.

Also try running "top" from tty2 and see if there is some process using a lot
of CPU.

Thanks,

Hans

Comment 12 RHEL Program Management 2010-06-07 16:14:52 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 13 David Cantrell 2010-06-18 18:27:59 UTC
If you can provide the information requested in comment 11, please attach and reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.