Bug 592602 - report library needs to run without config files
Summary: report library needs to run without config files
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: report   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Gavin Romig-Koch
QA Contact: David Kutálek
URL:
Whiteboard:
Keywords:
Depends On: 592601
Blocks: 592603
TreeView+ depends on / blocked
 
Reported: 2010-05-15 17:16 UTC by Gavin Romig-Koch
Modified: 2010-10-04 08:04 UTC (History)
4 users (show)

Fixed In Version: report-0.14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 592601
: 592603 (view as bug list)
Environment:
Last Closed: 2010-07-02 19:48:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gavin Romig-Koch 2010-05-15 17:16:42 UTC
+++ This bug was initially created as a clone of Bug #592601 +++

I strongly suspect that, within the installer, when anaconda makes use of the report library, there is no access to any config files (because there is no root file system to get config files from).

In any case the report library should be able to run even if all it's config files are inaccessible.  

To do this we need to make two changes:
   all places where config files are read, need to be able to recover if the files are not there, or if the files are unreadable, or any other error reading them.

   we need to mark in some machine readable way, the set of 'default' plugins that should be usable (by report) if the primary /etc/report.conf file is not readable.  Plugins should only be marked this way if they can be run without
configuration.

Comment 2 Gavin Romig-Koch 2010-05-17 14:52:49 UTC
I think this needs to be done as part of 6.0, rather than 6.1.  Report won't work correctly in the installer if it isn't done.

Comment 3 RHEL Product and Program Management 2010-05-17 15:07:08 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Gavin Romig-Koch 2010-05-17 19:18:48 UTC
This is fixed in the fedoraproject src repo.

Is there anything I can do to help get this qa acked?

Comment 7 releng-rhel@redhat.com 2010-07-02 19:48:18 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.