Bug 59261 - suexec clears SSL variables
Summary: suexec clears SSL variables
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-04 06:57 UTC by Zvi Har'El
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 20:34:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zvi Har'El 2002-02-04 06:57:44 UTC
Description of Problem:
CGI scripts running with suexec in a HTTPS virtual host, do not get the
environment varaibles HTTPS=on and those starting with SSL_

Version-Release number of selected component (if applicable):
apache-1.3.22-2, mod_ssl-2.8.5-1

How Reproducible:
Run the CGI script in a HTTPS Virtual server

#!/bin/sh
echo "Content-Type: text/plain"
echo
echo "HTTPS=$HTTPS"

Steps to Reproduce
1.
2. 
3. 

Actual Results:
HTTPS=

Expected Results:
HTTPS=on

Additional Information:
	
The reason this doesn't work is that /usr/sbin/suexec is compiled without
-DMOD_SSL flag, so that HTTP_ variables are not cleaned, but HTTPS and SSL_ are.
Installing mod_ssl does not replace suexec. It should be compiled with the
-DMOD_SSL even in a non-ssl environment - it does not fringe the security. This
is being discussed in the apache-dev mailing list and the compilation flag is
being dropped in apache 2.0

Comment 1 Brian Brock 2002-04-02 20:34:21 UTC
Verified fixed in 1.3.23-8.


Note You need to log in before you can comment on or make changes to this bug.