Bug 592625 - [abrt] crash in setroubleshoot-server-2.2.81-1.fc13: browser.py:355:on_delete_button_clicked:IndexError: list index out of range
Summary: [abrt] crash in setroubleshoot-server-2.2.81-1.fc13: browser.py:355:on_delete...
Status: CLOSED DUPLICATE of bug 578741
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot   
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Thomas Liu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:65bc917f
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-15 19:19 UTC by Carl G.
Modified: 2010-06-02 20:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 20:17:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (502 bytes, text/plain)
2010-05-15 19:19 UTC, Carl G.
no flags Details

Description Carl G. 2010-05-15 19:19:41 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python -E /usr/bin/sealert -s
comment: The AVCs are reported but not displayed.
component: setroubleshoot
executable: /usr/bin/sealert
kernel: 2.6.33.3-85.fc13.x86_64
package: setroubleshoot-server-2.2.81-1.fc13
reason: browser.py:355:on_delete_button_clicked:IndexError: list index out of range
release: Fedora release 13 (Goddard)

backtrace
-----
browser.py:355:on_delete_button_clicked:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/setroubleshoot/browser.py", line 355, in on_delete_button_clicked
    self.database.delete_signature(self.alert_list[self.current_alert].sig)
IndexError: list index out of range

Local variables in innermost frame:
widget: <gtk.Button object at 0x1bd20f0 (GtkButton at 0xfd09b0)>
self: <setroubleshoot.browser.BrowserApplet instance at 0x1b9bb90>

Comment 1 Carl G. 2010-05-15 19:19:43 UTC
Created attachment 414279 [details]
File: backtrace

Comment 2 Thomas Liu 2010-06-02 20:17:48 UTC

*** This bug has been marked as a duplicate of bug 578741 ***


Note You need to log in before you can comment on or make changes to this bug.