Bug 59264 - Conflicts with db1
Summary: Conflicts with db1
Status: CLOSED DUPLICATE of bug 58942
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-libs (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-04 08:56 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-05 16:40:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-02-04 08:56:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
gnome-libs and gnome-libs-devel conflict with db1 
package, /usr/bin/db1_dump185, /usr/lib/libdb1.so.2 and /usr/lib/libdb1.a

Surely db1 should either be required, or superceded, or the conflicting files 
should have different names if they are special to that gnome-libs build.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try and install gnome-libs-1.4.1.2.90-9 and gnome-libs-devel-1.4.1.2.90-9 on 
a system with db1 installed
2.
3.
	

Actual Results:  Fails of course with rpm conflict reported

Expected Results:  Should have succeeded

Additional info:

Comment 1 Havoc Pennington 2002-02-04 16:05:50 UTC
I was advised not to Obsoletes: db1 for now, I'm not sure of the rationale.

The files can't be renamed since that would change the libgnomeui ABI.

Comment 2 Need Real Name 2002-02-05 15:35:05 UTC
What about the ABI of things using db1 if we force the install, or lets compare 
breaking the abi to not being able to install it at all.

It's a rawhide build, lets break the abi of libgnomeui and stick a few >= in 
the requires lines.

If I haven't grasped something, please let me know.

Comment 3 Havoc Pennington 2002-02-05 16:39:54 UTC
Yes, we can't break the ABI. It being rawhide isn't relevant, rawhide gets
released eventually.

You shouldn't need the db1 package, is the idea. i.e. remove it.

Comment 4 Havoc Pennington 2002-02-26 19:55:15 UTC

*** This bug has been marked as a duplicate of 58942 ***

Comment 5 Need Real Name 2002-02-27 08:28:28 UTC
In that case can we at least have "Conflicts: db1" in the spec files.


Note You need to log in before you can comment on or make changes to this bug.