Bug 592655 - yelp-xsl XSL stylesheets for use with yelp
Summary: yelp-xsl XSL stylesheets for use with yelp
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-16 00:19 UTC by Matthias Clasen
Modified: 2010-06-17 14:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-17 14:44:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mbarnes: fedora-review+
dennis: fedora-cvs+


Attachments (Terms of Use)

Description Matthias Clasen 2010-05-16 00:19:12 UTC
These are new stylesheets for use with yelp.
They are now shipped as a separate module.

http://mclasen.fedorapeople.org/yelp-xsl.spec
http://mclasen.fedorapeople.org/yelp-xsl-2.31.1-1.fc14.src.rpm

Comment 1 Matthew Barnes 2010-05-26 19:20:38 UTC
rpmlint output:
yelp-xsl.src: I: checking
yelp-xsl.src: W: spelling-error Summary(en_US) stylesheets -> style sheets, style-sheets, stylishness
yelp-xsl.src: W: spelling-error %description -l en_US stylesheets -> style sheets, style-sheets, stylishness
yelp-xsl.src: W: non-standard-group Unspecified
yelp-xsl.src: I: checking-url http://download.gnome.org/sources/yelp-xsl (timeout 10 seconds)
yelp-xsl.src: W: no-cleaning-of-buildroot %install
yelp-xsl.src: W: no-cleaning-of-buildroot %clean
yelp-xsl.src: W: no-buildroot-tag
yelp-xsl.src: W: no-%clean-section
yelp-xsl.src: I: checking-url http://download.gnome.org/sources/yelp-xsl/2.31/yelp-xsl-2.31.1.tar.bz2 (timeout 10 seconds)

Builds fine, md5sum of tarball matches upstream.

"no-buildroot-tag" and "no-%clean-section" can be ignored per packaging guidelines.

I guess the other cleaning warnings can be ignored too since there's nothing to clean.

Not sure what the Group tag should be; yelp's is "Applications/System".

I'll leave it to you to fix or ignore the spelling errors.  I guess technically it's two words.

Typo: missing opening brace for %{version} in devel package.

Otherwise looks correct to me.

Comment 2 Parag AN(पराग) 2010-05-27 03:20:46 UTC
As per http://fedoraproject.org/wiki/PackagingGuidelines#Timestamps, you should use following

make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"

Comment 3 Matthias Clasen 2010-05-27 13:54:47 UTC
> As per http://fedoraproject.org/wiki/PackagingGuidelines#Timestamps, you should
> use following
>
> make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"   

I still have to find somebody who can explain a tangible benefit of this, other than giving reviewers the good feeling that they have something to criticize.

Comment 4 Matthias Clasen 2010-05-27 14:26:09 UTC
New version

http://mclasen.fedorapeople.org/yelp-xsl.spec
http://mclasen.fedorapeople.org/yelp-xsl-2.31.1-2.fc14.src.rpm  

changes
- use install -p
- fix %version} typo
- add Group tag

Comment 5 Matthew Barnes 2010-05-27 15:32:35 UTC
Approved.  The timestamp thing seems silly to me, but we comply.

Comment 6 Matthias Clasen 2010-05-27 19:14:11 UTC
New Package CVS Request
=======================
Package Name: yelp-xsl
Short Description: XSL Stylesheets for yelp
Owners: mclasen, mbarnes
Branches:

Comment 7 Dennis Gilmore 2010-05-27 22:37:07 UTC
CVS Done

Comment 8 Matthew Barnes 2010-06-17 14:44:56 UTC
Looks like this can be closed.


Note You need to log in before you can comment on or make changes to this bug.