Bug 59268 - kernel BUG at /usr/src/build/65535-i686/BUILD/kernel-2.4.17/linux/include/asm/spinlock.h:90!
kernel BUG at /usr/src/build/65535-i686/BUILD/kernel-2.4.17/linux/include/asm...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-04 04:57 EST by Need Real Name
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 03:10:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-02-04 04:57:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
booted from kernel-bigmem-2.4.17-0.6
2 8G 4xPIII machines died within hours of eachother, one had this in the logs:

Jan 30 23:55:18 tigris kernel: kernel BUG at /usr/src/build/65535-
i686/BUILD/kernel-2.4.17/linux/include/asm/spinlock.h:90!
Jan 30 23:55:18 tigris kernel: invalid operand: 0000


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.It just happens after uptime of a few days and withmost of the 8G ram used 
for file system buffers and only 2G swap which we think is all unused (it is 
whenever we look).

We also find unless we artifically limit the RAM with MEM=something less than 
8G the machine won't even bootup, but this is with all 2.4 bigmem/enterprise 
kernels we have tried, compiled ourselves OR prebuilt

2.
3.
	

Additional info:
Comment 1 Bill Nottingham 2002-03-28 03:56:43 EST
Does this behave any better with current rawhide kernels (2.4.18-0.x)?
Comment 2 Need Real Name 2002-04-02 03:10:34 EST
We have been trying 2.4.18-0.4bigmem with an uptime of 14 days so far.

The MEM= problem we also mentioned was fixed with a BIOS update from DELL but 
this did not fix uptime-crashing problems.

Anyway, possibly 2.4.18 has fixed it, if we have no further issues in 4-6 weeks 
we will presume it has and install that kernel on the other boxes.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.