Bug 592702 - After updating Fedora 13, NetworkManager UI will not run
Summary: After updating Fedora 13, NetworkManager UI will not run
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: dbus   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-16 11:26 UTC by Oded Arbel
Modified: 2013-03-06 04:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 08:41:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Oded Arbel 2010-05-16 11:26:34 UTC
Description of problem:
I install Fedora 13 from the beta release DVD, and everything worked fine. After updating to the current NetworkManager, neither nm-applet nor knetworkmanager will run any more.

nm-applet complains on the command line: 
---8<---
** (nm-applet:2746): WARNING **: <WARN>  request_name(): Could not acquire the NetworkManagerUserSettings service.
  Error: (9) Connection ":1.71" is not allowed to own the service "org.freedesktop.NetworkManagerUserSettings" due to security policies in the configuration file
---8<---

knetworkmanager complains in a dialog box:
---8<---
KNetworkManager cannot start because the installation is misconfigured.
System DBUS policy does not allow it to provide user settings;
contact your system administrator or distribution.
KNetworkManager will not start automatically in future.
---8<---

Version-Release number of selected component (if applicable):
0.8.1-0.1.git20100510

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 13 beta
2. upgrade to latest NetworkManager
3. restart computer.
4. log in
  
Actual results:
The NetworkManager UI does not come up at all, or shows an error message and exits.

Expected results:
The NetworkManager UI should come up with not error messages

Additional info:
I've tried to revert back to the packages from the Fedora 13, but it did not solve the problem. After reinstalling the Fedora 13, it worked - until I updated again. I think I can reproduce this 100% with this scenario, but I don't understand why, because the immediate suspect - the dbus configuration file /etc/dbus-1/system.d/NetworkManager.conf - is identical in both the installation ISO and the updates.

I also was able to workaround the problem by modifying the above mentioned file and adding
<allow own="org.freedesktop.NetworkManagerUserSettings"/>
in
<policy at_console="true">

Comment 1 Dan Williams 2010-05-18 00:34:57 UTC
Hmm, that strikes me as odd because nm-applet.conf should *already* have <allow own="org.freedesktop.NetworkManagerUserSettings"/> in the at_console section.  You don't want to make the modification to NetworkManager.conf, because taht file is for NetworkManager, not nm-applet.  However, the bug could have been fixed as a side-effect of modifying any of the files in /etc/dbus-1/system.d/

Did you restart after updating at all?


Colin, are we sure we've fixed the conf file re-reading race thing by now? I thought we had...

Comment 2 Oded Arbel 2010-05-18 08:41:36 UTC
After I updated the file, I restarted the messagebus service (and basically everything except from booting the system).

I just reinstalled and updated a VM with Fedora 13 and couldn't reproduce the problem, nor can I find my change in my current (working) real system - probably a recent update ate it.

Weird that I could reproduce the problem twice more after my initial install on my laptop but now its gone. Either it was a race condition that only affected my specific (and repeatable) use case - which is not far fetched, I tend to be very predictable ;-) or its a problem that was fixed in the last week.

Either way I'm closing this issue - thanks for the attention to this report, and sorry for the noise.


Note You need to log in before you can comment on or make changes to this bug.