Bug 592734 - [abrt] crash in projectM-pulseaudio-2.0.1-3.fc12: FTSize::CharSize: Process /usr/bin/projectM-pulseaudio was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in projectM-pulseaudio-2.0.1-3.fc12: FTSize::CharSize: Process /...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: projectM-pulseaudio
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jameson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a65f7bc92a346c57b3c97679c25...
: 603399 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-16 15:30 UTC by Craig
Modified: 2010-06-12 20:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-30 21:20:54 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (37.48 KB, text/plain)
2010-05-16 15:30 UTC, Craig
no flags Details

Description Craig 2010-05-16 15:30:32 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: projectM-pulseaudio
comment: Started program
component: projectM-pulseaudio
crash_function: FTSize::CharSize
executable: /usr/bin/projectM-pulseaudio
global_uuid: a65f7bc92a346c57b3c97679c2595cde1c7f7b32
kernel: 2.6.32.11-99.fc12.x86_64
package: projectM-pulseaudio-2.0.1-3.fc12
rating: 4
reason: Process /usr/bin/projectM-pulseaudio was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1.Launch application
2.
3.

Comment 1 Craig 2010-05-16 15:30:33 UTC
Created attachment 414372 [details]
File: backtrace

Comment 2 Jameson 2010-05-21 17:08:41 UTC
I believe that this issue is actually caused by an upgrade from libprojectM-2.0.1-3 to libprojectM-2.0.1-4.  There have been symlinks to fonts removed, but I'm not sure of an appropriate way to update config files in home directories for this.  Please, try running:
sed -i 's/projectM\/fonts/fonts\/bitstream-vera/g' /home/*/.projectM/config.inp

If you run projectM as more than one user, you'll need to run that as root, and it should update your config file to point to the real fonts.

Comment 3 Craig 2010-05-21 22:54:21 UTC
(In reply to comment #2)
> I believe that this issue is actually caused by an upgrade from
> libprojectM-2.0.1-3 to libprojectM-2.0.1-4.  There have been symlinks to fonts
> removed, but I'm not sure of an appropriate way to update config files in home
> directories for this.  Please, try running:
> sed -i 's/projectM\/fonts/fonts\/bitstream-vera/g' /home/*/.projectM/config.inp
> 
> If you run projectM as more than one user, you'll need to run that as root, and
> it should update your config file to point to the real fonts.    

 This worked perfectly.  Thank you very much.

Comment 4 Jameson 2010-06-12 20:57:51 UTC
*** Bug 603399 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.