Bug 592785 - usb kvm switch sometimes kernel oops dev_get_drvdata
usb kvm switch sometimes kernel oops dev_get_drvdata
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-16 18:02 EDT by Trevor Cordes
Modified: 2010-08-23 18:02 EDT (History)
7 users (show)

See Also:
Fixed In Version: kernel-2.6.32.19-163.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 18:02:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
more detailed dmesg output (5.91 KB, text/plain)
2010-05-16 18:02 EDT, Trevor Cordes
no flags Details
The fix (2 commits) (3.28 KB, patch)
2010-06-05 20:08 EDT, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Trevor Cordes 2010-05-16 18:02:10 EDT
Description of problem:
I have a USB/DVI KVM switch and I switch between the F12 box and an XP box sometimes hundreds of times an hour.  Once in a blue moon F12 oops's and goes wonky.  No rhyme or reason to it.  Sometimes I'll switch 1000+ times without issue.  XP box never seems to have a problem.

May 16 15:36:22 pog kernel: BUG: unable to handle kernel NULL pointer dereference at 00000020
May 16 15:36:22 pog kernel: IP: [<c0660028>] dev_get_drvdata+0xc/0x1c
May 16 15:36:22 pog kernel: *pdpt = 000000001719c001 *pde = 00000000c6f04067
May 16 15:36:22 pog kernel: Oops: 0000 [#1] SMP

attaching more output


Version-Release number of selected component (if applicable):
kernel-PAE-2.6.32.11-99.fc12.i686

How reproducible:
difficult, seemingly random and at extremely long intervals

Steps to Reproduce:
1. switch computers on KVM switch often
2.
3.
  
Actual results:
oops, can't gain control of mouse/keyboard after that, remote logins start freezing

Expected results:
system runs fine, kb/mse work fine

Additional info:
tainted with nvidia binary driver from rpm-fusion, sorry
Comment 1 Trevor Cordes 2010-05-16 18:02:49 EDT
Created attachment 414421 [details]
more detailed dmesg output
Comment 2 Pete Zaitcev 2010-06-05 20:08:28 EDT
Created attachment 421519 [details]
The fix (2 commits)
Comment 3 Stanislaw Gruszka 2010-06-07 15:16:59 EDT
Trevor,

Are you able to test above fix, or should I prepare test kernel for you?
Comment 4 Trevor Cordes 2010-07-27 16:07:40 EDT
Hi, I haven't done a kernel compile in a few years.  I stick to the stock Fedora ones mostly now.  I'm on F12 currently.

I could run a test kernel you provide if it won't mess up my F12 system.  Of course, if security errata is issued I'd be forced to go back to stock ones.

This bug is so obscure (only hit me once) it may be a difficult one to test for: hard to tell if it's fixed or just not hitting the pathological case.

But I will help out however I can.  Thanks!
Comment 5 Stanislaw Gruszka 2010-07-28 04:51:58 EDT
I looked at patch and oops messages again, I'm pretty sure patch fix the problem. I will post patch to fedora-kernel mailing list, it should be included soon in F-12 kernel. F-13 will switch to 2.6.34 kernel, so problem will be fixed there as well.
Comment 6 Chuck Ebbert 2010-08-06 00:45:14 EDT
Patch went in 2.6.32.17-157
Comment 7 Fedora Update System 2010-08-18 06:50:19 EDT
kernel-2.6.32.19-162.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kernel-2.6.32.19-162.fc12
Comment 8 Fedora Update System 2010-08-18 16:45:52 EDT
kernel-2.6.32.19-163.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kernel-2.6.32.19-163.fc12
Comment 9 Fedora Update System 2010-08-19 22:00:03 EDT
kernel-2.6.32.19-163.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kernel-2.6.32.19-163.fc12
Comment 10 Trevor Cordes 2010-08-20 04:16:50 EDT
Thanks, I'll try it out and report back if the oops happens again.  However, like I said before, this bug is very very rare so no recurrence in a reasonable timeframe doesn't necessarily mean it's fixed.
Comment 11 Stanislaw Gruszka 2010-08-20 06:54:17 EDT
Sure, just reopen bug if you see the problem again, but I believe you will not see it because is fixed :-)
Comment 12 Fedora Update System 2010-08-23 18:01:50 EDT
kernel-2.6.32.19-163.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.