Bug 592788 - dependency problems with setroubleshoot-server
Summary: dependency problems with setroubleshoot-server
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-16 22:18 UTC by Jan-Frode Myklebust
Modified: 2010-05-17 12:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-17 12:54:45 UTC
Type: ---


Attachments (Terms of Use)

Description Jan-Frode Myklebust 2010-05-16 22:18:26 UTC
Description of problem:

Can't install setroubleshoot-server.x86_64 on fully updated fedora-13 beta.

Version-Release number of selected component (if applicable):

fedora-13 beta.

How reproducible:

100%

Steps to Reproduce:
1. Install fedora 13 beta (from netboot installer)
2. Update (yum update)
3. Try installing setroubleshoot-server by running: "yum install setroubleshoot-server"
  
Actual results:

Yum fails to install this package because of dependency problems. Adding --skip-broken doesn't help.


Expected results:

setroubleshoot-server installed.

Additional info:

Full output:

# yum install setroubleshoot-server
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package setroubleshoot-server.x86_64 0:2.2.81-1.fc13 set to be updated
--> Processing Dependency: libselinux-python >= 1.30.15-1 for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: setroubleshoot-plugins >= 2.0.4 for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: audit-libs-python >= 1.2.6-3 for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: policycoreutils-python for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: setools-libs-python for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libxml2-python for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: python-slip-dbus for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: gtk2 for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libnotify for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: pygobject2 for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: dbus-python for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: dbus for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libpangocairo-1.0.so.0()(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libapol.so.4()(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libfreetype.so.6()(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libpango-1.0.so.0()(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libnotify.so.1()(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libgtk-x11-2.0.so.0()(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libpangoft2-1.0.so.0()(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libcairo.so.2()(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libatk-1.0.so.0()(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libgdk-x11-2.0.so.0()(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libfontconfig.so.1()(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Processing Dependency: libqpol.so.1()(64bit) for package: setroubleshoot-server-2.2.81-1.fc13.x86_64
--> Running transaction check
---> Package atk.x86_64 0:1.30.0-1.fc13 set to be updated
---> Package audit-libs-python.x86_64 0:2.0.4-3.fc13 set to be updated
---> Package cairo.x86_64 0:1.8.10-1.fc13 set to be updated
--> Processing Dependency: libpng12.so.0(PNG12_0)(64bit) for package: cairo-1.8.10-1.fc13.x86_64
--> Processing Dependency: libpixman-1.so.0()(64bit) for package: cairo-1.8.10-1.fc13.x86_64
--> Processing Dependency: libX11.so.6()(64bit) for package: cairo-1.8.10-1.fc13.x86_64
--> Processing Dependency: libXrender.so.1()(64bit) for package: cairo-1.8.10-1.fc13.x86_64
--> Processing Dependency: libpng12.so.0()(64bit) for package: cairo-1.8.10-1.fc13.x86_64
---> Package dbus.x86_64 1:1.2.24-1.fc13 set to be updated
---> Package dbus-python.x86_64 0:0.83.0-6.fc12 set to be updated
---> Package fontconfig.x86_64 0:2.8.0-1.fc13 set to be updated
---> Package freetype.x86_64 0:2.3.11-3.fc13 set to be updated
---> Package gtk2.x86_64 0:2.20.1-1.fc13 set to be updated
--> Processing Dependency: libXrandr >= 1.2.99.4-2 for package: gtk2-2.20.1-1.fc13.x86_64
--> Processing Dependency: libtiff >= 3.6.1 for package: gtk2-2.20.1-1.fc13.x86_64
--> Processing Dependency: hicolor-icon-theme for package: gtk2-2.20.1-1.fc13.x86_64
--> Processing Dependency: libXrandr.so.2()(64bit) for package: gtk2-2.20.1-1.fc13.x86_64
--> Processing Dependency: libtiff.so.3()(64bit) for package: gtk2-2.20.1-1.fc13.x86_64
--> Processing Dependency: libXdamage.so.1()(64bit) for package: gtk2-2.20.1-1.fc13.x86_64
--> Processing Dependency: libXcursor.so.1()(64bit) for package: gtk2-2.20.1-1.fc13.x86_64
--> Processing Dependency: libcups.so.2()(64bit) for package: gtk2-2.20.1-1.fc13.x86_64
--> Processing Dependency: libXi.so.6()(64bit) for package: gtk2-2.20.1-1.fc13.x86_64
--> Processing Dependency: libjasper.so.1()(64bit) for package: gtk2-2.20.1-1.fc13.x86_64
--> Processing Dependency: libXext.so.6()(64bit) for package: gtk2-2.20.1-1.fc13.x86_64
--> Processing Dependency: libXcomposite.so.1()(64bit) for package: gtk2-2.20.1-1.fc13.x86_64
--> Processing Dependency: libXinerama.so.1()(64bit) for package: gtk2-2.20.1-1.fc13.x86_64
--> Processing Dependency: libXfixes.so.3()(64bit) for package: gtk2-2.20.1-1.fc13.x86_64
--> Processing Dependency: libjpeg.so.62()(64bit) for package: gtk2-2.20.1-1.fc13.x86_64
---> Package libnotify.x86_64 0:0.4.5-4.fc13 set to be updated
--> Processing Dependency: desktop-notification-daemon for package: libnotify-0.4.5-4.fc13.x86_64
---> Package libselinux-python.x86_64 0:2.0.90-5.fc13 set to be updated
---> Package libxml2-python.x86_64 0:2.7.7-1.fc13 set to be updated
---> Package pango.x86_64 0:1.28.0-1.fc13 set to be updated
--> Processing Dependency: libthai >= 0.1.9 for package: pango-1.28.0-1.fc13.x86_64
--> Processing Dependency: libthai.so.0(LIBTHAI_0.1)(64bit) for package: pango-1.28.0-1.fc13.x86_64
--> Processing Dependency: libthai.so.0()(64bit) for package: pango-1.28.0-1.fc13.x86_64
--> Processing Dependency: libXft.so.2()(64bit) for package: pango-1.28.0-1.fc13.x86_64
---> Package policycoreutils-python.x86_64 0:2.0.82-13.fc13 set to be updated
--> Processing Dependency: policycoreutils = 2.0.82-13.fc13 for package: policycoreutils-python-2.0.82-13.fc13.x86_64
--> Processing Dependency: libsemanage-python >= 2.0.43-4 for package: policycoreutils-python-2.0.82-13.fc13.x86_64
---> Package pygobject2.x86_64 0:2.21.1-6.fc13 set to be updated
---> Package python-slip-dbus.noarch 0:0.2.9-1.fc13 set to be updated
--> Processing Dependency: python-slip = 0.2.9-1.fc13 for package: python-slip-dbus-0.2.9-1.fc13.noarch
--> Processing Dependency: polkit >= 0.94 for package: python-slip-dbus-0.2.9-1.fc13.noarch
--> Processing Dependency: python-decorator for package: python-slip-dbus-0.2.9-1.fc13.noarch
---> Package setools-libs.x86_64 0:3.3.6-4.fc12 set to be updated
---> Package setools-libs-python.x86_64 0:3.3.6-4.fc12 set to be updated
---> Package setroubleshoot-plugins.noarch 0:2.1.50-1.fc13 set to be updated
--> Running transaction check
---> Package cups-libs.x86_64 1:1.4.3-6.fc13 set to be updated
--> Processing Dependency: libavahi-common.so.3()(64bit) for package: 1:cups-libs-1.4.3-6.fc13.x86_64
--> Processing Dependency: libavahi-client.so.3()(64bit) for package: 1:cups-libs-1.4.3-6.fc13.x86_64
---> Package hicolor-icon-theme.noarch 0:0.12-1.fc13 set to be updated
---> Package jasper-libs.x86_64 0:1.900.1-15.fc13 set to be updated
---> Package libX11.x86_64 0:1.3.1-3.fc13 set to be updated
--> Processing Dependency: libX11-common = 1.3.1-3.fc13 for package: libX11-1.3.1-3.fc13.x86_64
--> Processing Dependency: libxcb.so.1()(64bit) for package: libX11-1.3.1-3.fc13.x86_64
---> Package libXcomposite.x86_64 0:0.4.1-2.fc13 set to be updated
---> Package libXcursor.x86_64 0:1.1.10-4.fc13 set to be updated
--> Processing Dependency: dmz-cursor-themes for package: libXcursor-1.1.10-4.fc13.x86_64
---> Package libXdamage.x86_64 0:1.1.2-2.fc13 set to be updated
---> Package libXext.x86_64 0:1.1-2.fc13 set to be updated
---> Package libXfixes.x86_64 0:4.0.4-2.fc13 set to be updated
---> Package libXft.x86_64 0:2.1.14-1.fc13 set to be updated
---> Package libXi.x86_64 0:1.3-2.fc13 set to be updated
---> Package libXinerama.x86_64 0:1.1-2.fc13 set to be updated
---> Package libXrandr.x86_64 0:1.3.0-5.fc13 set to be updated
---> Package libXrender.x86_64 0:0.9.5-1.fc13 set to be updated
---> Package libjpeg.x86_64 0:6b-46.fc12 set to be updated
---> Package libpng.x86_64 2:1.2.43-1.fc13 set to be updated
---> Package libsemanage-python.x86_64 0:2.0.45-1.fc13 set to be updated
---> Package libthai.x86_64 0:0.1.14-2.fc13 set to be updated
---> Package libtiff.x86_64 0:3.9.2-3.fc13 set to be updated
---> Package pixman.x86_64 0:0.18.0-1.fc13 set to be updated
---> Package policycoreutils-python.x86_64 0:2.0.82-13.fc13 set to be updated
--> Processing Dependency: policycoreutils = 2.0.82-13.fc13 for package: policycoreutils-python-2.0.82-13.fc13.x86_64
---> Package polkit.x86_64 0:0.96-1.fc13 set to be updated
--> Processing Dependency: ConsoleKit for package: polkit-0.96-1.fc13.x86_64
--> Processing Dependency: libeggdbus-1.so.0()(64bit) for package: polkit-0.96-1.fc13.x86_64
---> Package python-decorator.noarch 0:3.1.2-2.fc13 set to be updated
---> Package python-slip.noarch 0:0.2.9-1.fc13 set to be updated
---> Package xfce4-notifyd.x86_64 0:0.1.0-3.fc12 set to be updated
--> Processing Dependency: libsexy.so.2()(64bit) for package: xfce4-notifyd-0.1.0-3.fc12.x86_64
--> Processing Dependency: libxfconf-0.so.2()(64bit) for package: xfce4-notifyd-0.1.0-3.fc12.x86_64
--> Processing Dependency: libxfcegui4.so.4()(64bit) for package: xfce4-notifyd-0.1.0-3.fc12.x86_64
--> Processing Dependency: libxfce4util.so.4()(64bit) for package: xfce4-notifyd-0.1.0-3.fc12.x86_64
--> Processing Dependency: libglade-2.0.so.0()(64bit) for package: xfce4-notifyd-0.1.0-3.fc12.x86_64
--> Running transaction check
---> Package ConsoleKit.x86_64 0:0.4.1-5.fc13 set to be updated
--> Processing Dependency: libck-connector.so.0()(64bit) for package: ConsoleKit-0.4.1-5.fc13.x86_64
---> Package avahi.x86_64 0:0.6.25-6.fc13 set to be updated
--> Processing Dependency: libdaemon >= 0.11 for package: avahi-0.6.25-6.fc13.x86_64
--> Processing Dependency: libdaemon.so.0()(64bit) for package: avahi-0.6.25-6.fc13.x86_64
---> Package dmz-cursor-themes.noarch 0:0.4-3.fc13 set to be updated
---> Package eggdbus.x86_64 0:0.6-2.fc13 set to be updated
---> Package libX11-common.noarch 0:1.3.1-3.fc13 set to be updated
---> Package libglade2.x86_64 0:2.6.4-3.fc12 set to be updated
---> Package libsexy.x86_64 0:0.1.11-15.fc13 set to be updated
--> Processing Dependency: enchant for package: libsexy-0.1.11-15.fc13.x86_64
---> Package libxcb.x86_64 0:1.5-1.fc13 set to be updated
--> Processing Dependency: libXau.so.6()(64bit) for package: libxcb-1.5-1.fc13.x86_64
---> Package libxfce4util.x86_64 0:4.6.1-2.fc12 set to be updated
---> Package libxfcegui4.x86_64 0:4.6.3-1.fc13 set to be updated
--> Processing Dependency: libICE.so.6()(64bit) for package: libxfcegui4-4.6.3-1.fc13.x86_64
--> Processing Dependency: libstartup-notification-1.so.0()(64bit) for package: libxfcegui4-4.6.3-1.fc13.x86_64
--> Processing Dependency: libSM.so.6()(64bit) for package: libxfcegui4-4.6.3-1.fc13.x86_64
---> Package policycoreutils-python.x86_64 0:2.0.82-13.fc13 set to be updated
--> Processing Dependency: policycoreutils = 2.0.82-13.fc13 for package: policycoreutils-python-2.0.82-13.fc13.x86_64
---> Package xfconf.x86_64 0:4.6.1-5.fc13 set to be updated
--> Processing Dependency: dbus-x11 for package: xfconf-4.6.1-5.fc13.x86_64
--> Running transaction check
---> Package ConsoleKit-libs.x86_64 0:0.4.1-5.fc13 set to be updated
---> Package dbus-x11.x86_64 1:1.2.24-1.fc13 set to be updated
---> Package enchant.x86_64 1:1.6.0-1.fc13 set to be updated
--> Processing Dependency: libhunspell-1.2.so.0()(64bit) for package: 1:enchant-1.6.0-1.fc13.x86_64
---> Package libICE.x86_64 0:1.0.6-2.fc13 set to be updated
---> Package libSM.x86_64 0:1.1.0-7.fc12 set to be updated
---> Package libXau.x86_64 0:1.0.5-1.fc12 set to be updated
---> Package libdaemon.x86_64 0:0.14-1.fc13 set to be updated
---> Package policycoreutils-python.x86_64 0:2.0.82-13.fc13 set to be updated
--> Processing Dependency: policycoreutils = 2.0.82-13.fc13 for package: policycoreutils-python-2.0.82-13.fc13.x86_64
---> Package startup-notification.x86_64 0:0.10-4.fc13 set to be updated
--> Processing Dependency: libxcb-atom.so.1()(64bit) for package: startup-notification-0.10-4.fc13.x86_64
--> Processing Dependency: libxcb-event.so.1()(64bit) for package: startup-notification-0.10-4.fc13.x86_64
--> Processing Dependency: libxcb-aux.so.0()(64bit) for package: startup-notification-0.10-4.fc13.x86_64
--> Running transaction check
---> Package hunspell.x86_64 0:1.2.8-17.fc13 set to be updated
---> Package policycoreutils-python.x86_64 0:2.0.82-13.fc13 set to be updated
--> Processing Dependency: policycoreutils = 2.0.82-13.fc13 for package: policycoreutils-python-2.0.82-13.fc13.x86_64
---> Package xcb-util.x86_64 0:0.3.6-1.fc12 set to be updated
--> Finished Dependency Resolution
Error: Package: policycoreutils-python-2.0.82-13.fc13.x86_64 (fedora)
           Requires: policycoreutils = 2.0.82-13.fc13
           Installed: policycoreutils-2.0.82-18.fc13.x86_64 (installed)
           Available: policycoreutils-2.0.82-13.fc13.x86_64 (fedora)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 1 Jan-Frode Myklebust 2010-05-16 22:57:14 UTC
Same problem when trying to install policycoreutils-sandbox.x86_64..

Comment 2 Jan-Frode Myklebust 2010-05-16 23:16:56 UTC
And enabling the [updates-testing]-repo fixes it..

# yum install --enablerepo=updates-testing policycoreutils-python
=========================================================================================================
 Package                         Arch            Version                  Repository                Size
=========================================================================================================
Installing:
 policycoreutils-python          x86_64          2.0.82-18.fc13           updates-testing          329 k
Installing for dependencies:
 audit-libs-python               x86_64          2.0.4-3.fc13             fedora                    62 k
 libselinux-python               x86_64          2.0.90-5.fc13            fedora                   200 k
 libsemanage-python              x86_64          2.0.45-1.fc13            fedora                    81 k
 setools-libs                    x86_64          3.3.6-4.fc12             fedora                   370 k
 setools-libs-python             x86_64          3.3.6-4.fc12             fedora                   203 k

Transaction Summary
=========================================================================================================
Install       6 Package(s)
Upgrade       0 Package(s)

Total download size: 1.2 M
Installed size: 4.7 M
Is this ok [y/N]: y

Comment 3 Daniel Walsh 2010-05-17 12:54:45 UTC
I just marked that update as stable.


Note You need to log in before you can comment on or make changes to this bug.