Bug 592799 - syntax mistake in /etc/bashrc pathmunge
syntax mistake in /etc/bashrc pathmunge
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 592825
  Show dependency treegraph
 
Reported: 2010-05-16 22:14 EDT by Aron Griffis
Modified: 2010-05-24 09:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 592825 (view as bug list)
Environment:
Last Closed: 2010-05-24 09:22:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix it (489 bytes, patch)
2010-05-16 22:14 EDT, Aron Griffis
no flags Details | Diff

  None (edit)
Description Aron Griffis 2010-05-16 22:14:40 EDT
Created attachment 414438 [details]
fix it

Description of problem:
pathmunch in /etc/bashrc quotes the regex. Current versions of bash require the regex to be unquoted (just like glob-matching), so the regex will never match. Note the var $1 should still be quoted to prevent interpretation of regex chars.

Version-Release number of selected component (if applicable):
setup-2.8.17-1.fc13.noarch

Actual results:
$PATH with dups

Expected results:
$PATH without dups
Comment 1 Ondrej Vasik 2010-05-17 01:46:31 EDT
Thanks for report, I see - changed between 3.1 and 3.2 . Will fix that...
Comment 2 Ondrej Vasik 2010-05-19 06:27:08 EDT
Fixed in setup-2.8.19-1.fc14 ...
Comment 3 Ondrej Vasik 2010-05-24 09:22:53 EDT
I used a bit different approach - no bashism, case is used - it seems to be even faster (and from my tests even a bit better for some obscure PATHs). As this change is no longer required, I'll mark this bugzilla as NEXTRELEASE.

See https://bugzilla.redhat.com/show_bug.cgi?id=544652 for the setup package updates which do contain the new patmunge() with case.

Note You need to log in before you can comment on or make changes to this bug.