Bug 592829 - Add support for newer VIA chipsets to kernel drm
Summary: Add support for newer VIA chipsets to kernel drm
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-17 06:32 UTC by Timothy Lee
Modified: 2014-06-30 04:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 13:05:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to support newer VIA graphic chipsets in kernel drm (4.93 KB, patch)
2010-05-17 06:32 UTC, Timothy Lee
no flags Details | Diff

Description Timothy Lee 2010-05-17 06:32:14 UTC
Created attachment 414460 [details]
Patch to support newer VIA graphic chipsets in kernel drm

Currently newer VIA graphic chipsets including CN700, VM800, P4M800Pro, P4M890, K8M890, CX700, P4M900 and VN896 are not supported by the kernel drm, even though they can already be supported using existing code.

This problems has always existed in RHEL <= 5.5

The attached patch is based on via drm code in latest kernel.  Apart from adding the missing PCI ids, it defines a new class of display engine VIA_DX9_0, which is identical to VIA_PRO_GROUP_A but has no 3D capabilities.

The changes made by this patch are localized to via.ko, and does not impact other modules.  Support for existing VIA graphic chipsets are also unaffected.

Comment 1 RHEL Product and Program Management 2014-03-07 13:37:02 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 2 RHEL Product and Program Management 2014-06-02 13:05:18 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.