Bug 5929 - Requires egcs to build
Requires egcs to build
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gated (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-13 19:36 EDT by andrewem
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-17 06:39:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andrewem 1999-10-13 19:36:54 EDT
I understand that egcs produced better code than gcc for x86
at one time, but this was never true for all architectures
(example: gcc and egcs for ARM were always identical).
Since egcs has been merged back into gcc, more and more of
these special cased spec files are gonna be causing
headaches in the future as well.

If egcs is on a system, it is very likely the only compiler
on the system, and already owns the cc (and gcc) symlink.

At the very least, the following would do the same in a much
more portable manner:

  if [ -e `type egcs` ] ; then \
    make CC=egcs ; \
  else \
    make
  fi

This will work even if egcs is a symlink (to gcc).
Comment 1 andrewem 1999-10-13 19:40:59 EDT
Uggh...that should have been

  if [ -e `type -p egcs` ] ; then \
    make CC=egcs ; \
  else \
    make ; \
  fi
Comment 2 Bernhard Rosenkraenzer 2000-02-17 06:39:59 EST
Fixed in 3.5.11-1

Note You need to log in before you can comment on or make changes to this bug.