Bug 59292 - Mozilla downloads wrong JRE plug-in
Mozilla downloads wrong JRE plug-in
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
7.1
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-04 14:10 EST by Robert M. Riches Jr.
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-16 14:36:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert M. Riches Jr. 2002-02-04 14:10:47 EST
Description of Problem: Mozilla downloads the wrong JRE
when it encounters a web page that needs a version 1.3.1
Java 2 plug-in.

Version-Release number of selected component (if applicable):
mozilla-0.8.1-5

How Reproducible:
100%

Steps to Reproduce:
1. Invoke mozilla
2. Go to page that requires a JRE 1.3.1 Java2 plug-in.
3. Make and check a hard link (cd /tmp; ln jre131i.xpi something;
    sleep 3600; unzip -t something)

Actual Results:
Mozilla downloaded an i386 JRE, which is not correct for an Alpha
machine.  (X86 may be the worst surviving instruction set architecture
on this planet, but it's certainly not the only one.)  Then, mozilla
pops up a window instructing the user to downloads a Losedows version
of the plug-in:
ftp://ftp.netscape.com/pub/netscape6/english/6.0/windows/win32/smartupdate/jre13i.exe
for Windows

Expected Results:
Mozilla should download a JRE appropriate for the architecture on
which it is actually running.  Or, better yet, if possible, it should
use the existing JDK already installed on the machine.

Additional Information:
I apologize for not being able to provide an URL that shows the
problem.  One case I saw was money.net's free 14-day trial for their
streaming real-time stock quote service.  Another is the charts page
on my stock broker's web site, and an account with the broker is
required to get to that area.  (It appears a fairly reliable predictor
of a page that will show this problem for Mozilla is a page that will
cause Netscape 4.77 to throw a segment fault.)
Comment 1 Christopher Blizzard 2002-04-29 13:35:10 EDT
So what would be the right behaviour here?  I don't think that we have a working
JVM for mozilla for the alpha, right?  Should I just disable the dialog?
Comment 2 Robert M. Riches Jr. 2002-04-29 13:50:59 EDT
That would be better than the present behavior.  If Mozilla requires a whole
separate JVM,
separate from a JDK the user might have already have on the machine, and if
there is no
downloadable JVM for the architecture in question, then it would be better to
inform the
user that no JVM exists for that machine.

Thanks.
Comment 3 john.goshdigian 2002-04-30 14:42:27 EDT
JVM exists for Alpha, the problem is with the plug-in.
So, it would be better to inform the user that no plug-in exists for that machine.
Comment 4 Christopher Blizzard 2002-04-30 15:51:19 EDT
Where is the JVM?
Comment 5 Christopher Blizzard 2002-05-16 14:36:24 EDT
I fixed this in the 0.9.9 build by not allowing the plugin downloader to go to
the downloader site.  Downloading and installing a .xpi as a user doesn't work
correctly in any case.
Comment 6 Christopher Blizzard 2002-05-16 14:37:08 EDT
Anyway, fixed in the last 7.2 errata.

Note You need to log in before you can comment on or make changes to this bug.