Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 592922 - unix2dos has been merged into dos2unix at upstream
unix2dos has been merged into dos2unix at upstream
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: unix2dos (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 566122 (view as bug list)
Depends On: 566122
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 07:40 EDT by Till Maas
Modified: 2010-08-23 21:31 EDT (History)
3 users (show)

See Also:
Fixed In Version: dos2unix-5.1.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 21:31:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2010-05-17 07:40:50 EDT
Description of problem:
http://www.xs4all.nl/~waterlan/dos2unix.html#UNIX2DOS
| Since version 5.0 is Unix2Dos included in the Dos2Unix package. The separate Unix2Dos package is now redundant.

unix2dos should be retired once dos2unix has been updated.
Comment 1 Chen Lei 2010-07-14 04:27:52 EDT
Tim, 

Is there any blocker for updating dos2unix to the lastest version?
Comment 2 Tim Waugh 2010-07-14 05:46:59 EDT
No, just the time to do it.
Comment 3 Bug Zapper 2010-07-30 07:39:11 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Chen Lei 2010-08-18 01:37:25 EDT
(In reply to comment #2)
> No, just the time to do it.

Hi Tim,

Would mind to upload this srpm to git repo? It seems dos2unix 4.x has some bugs when recognizing text files, dos2unix 3.x don't have the same issue.

http://supercyper.fedorapeople.org/dos2unix-5.1-1.fc13.src.rpm

rpmlint dos2unix-*
dos2unix.x86_64: W: spelling-error %description -l en_US versa -> avers, verse, verst

Notes: I don't split unix2dos into another subpackage because both binaries use the same man page files.
Comment 5 Tim Waugh 2010-08-18 07:07:30 EDT
Thanks.  I've built this in rawhide now -- not sure if there is still time to get this in for Fedora 14.

The eo-x locale seems to be completely broken so I opted to remove it altogether rather than mv it over eo.

I'll let the upstream maintainer know about that, and about the weird executable permissions.

Thanks for working on this.  Have you considered being the Fedora maintainer (or, if you prefer, co-maintainer) for this package?  I don't get very much time to give attention to it as you have seen!
Comment 6 Tim Waugh 2010-08-18 07:52:26 EDT
I've built it for Fedora 14 now.
Comment 7 Fedora Update System 2010-08-18 07:53:59 EDT
dos2unix-5.1-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/dos2unix-5.1-1.fc14
Comment 8 Tim Waugh 2010-08-18 08:42:08 EDT
I spoke to the upstream maintain about eo-x -- he says it's a work-around for there being no UTF-8 support on DOS.  As Fedora does have UTF-8 support, I think the correct approach is to remove eo-x from our packaging of dos2unix.
Comment 9 Fedora Update System 2010-08-18 15:51:44 EDT
dos2unix-5.1-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dos2unix'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/dos2unix-5.1-1.fc14
Comment 10 Chen Lei 2010-08-18 23:03:49 EDT
(In reply to comment #8)
> I spoke to the upstream maintain about eo-x -- he says it's a work-around for
> there being no UTF-8 support on DOS.  As Fedora does have UTF-8 support, I
> think the correct approach is to remove eo-x from our packaging of dos2unix.

Thanks a lot, this issue is more clear now.(In reply to comment #5)

> Thanks for working on this.  Have you considered being the Fedora maintainer
> (or, if you prefer, co-maintainer) for this package?  I don't get very much
> time to give attention to it as you have seen!
I applied for the co-maintainship of dos2unix a while ago:)
Comment 11 Tim Waugh 2010-08-19 06:08:18 EDT
(In reply to comment #10)
> I applied for the co-maintainship of dos2unix a while ago:)

Oh, really?  Sorry, I don't think I got an email about it.  Anyway, ACLs approved now. :-)

I think Erwin has released 5.1.1 now...
Comment 12 Chen Lei 2010-08-19 13:02:03 EDT
(In reply to comment #11)
> (In reply to comment #10)
> I think Erwin has released 5.1.1 now...

I now update dos2unix to 5.1.1 :)
Comment 13 Fedora Update System 2010-08-19 13:06:40 EDT
dos2unix-5.1.1-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/dos2unix-5.1.1-1.fc14
Comment 14 Tim Waugh 2010-08-23 11:13:00 EDT
*** Bug 566122 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2010-08-23 21:31:08 EDT
dos2unix-5.1.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.