Bug 592934 - ibm-prtm package needs to be updated
ibm-prtm package needs to be updated
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-utilities (Show other bugs)
1.2
x86_64 All
low Severity high
: ---
: ---
Assigned To: Clark Williams
David Sommerseth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 08:21 EDT by IBM Bug Proxy
Modified: 2016-05-22 19:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Support added for SMI remediation for the IBM BladeCenter HS22V, IBM System x3650 M3 and x3550 M3 systems. In addition, the init script has been fixed so that it is now compliant with Linux Standard Base (LSB) guidelines, thus resolving this issue.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-25 08:59:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 63811 None None None Never
Red Hat Product Errata RHEA-2010:0654 normal SHIPPED_LIVE Red Hat Enterprise MRG Realtime enhancement update 2010-08-25 08:59:00 EDT

  None (edit)
Description IBM Bug Proxy 2010-05-17 08:21:19 EDT
=Comment: #0=================================================
Vernon Mauery <vernux@us.ibm.com> - 
The latest ibm-prtm package has been released on its sourceforge page: 
https://sourceforge.net/projects/ibm-prtm/

Version 1.7 supports the new platforms that were added with the latest i7core_edac driver that was
recently pushed.

Major changes in 1.7 that might be of notice:
1) The init script is now LSB compliant so it should be able to be used AS-IS on all LSB compliant
distros.
2) Point 1 includes taking out the ipmi init code that used to be in the script and replacing it
with a dependency on ipmidrv in the INIT INFO section
3) the init script has been changed to expect that the daemon script lives in /usr/sbin instead of
/sbin, since that makes more sense.  The Makefile has been changed to suit (in case anybody uses that).

Please pull this in as the latest ibm-prtm package.
Comment 1 IBM Bug Proxy 2010-05-24 16:41:33 EDT
------- Comment From vernux@us.ibm.com 2010-05-24 16:31 EDT-------
Notes from the weekly call:

1) ibm-prtmd moved from /sbin to /usr/sbin, so packaging needs to be aware of that.
2) ibm-prtm script depends on ipmi, so package needs to depend on OpenIPMI-tools.
Comment 2 Clark Williams 2010-07-19 16:45:19 EDT
ibm-prtm-1.7-2 is in testing for an upcoming security errata.
Comment 3 IBM Bug Proxy 2010-08-02 11:52:12 EDT
------- Comment From vernux@us.ibm.com 2010-08-02 11:45 EDT-------
I must have missed the dependency because I don't see it listed in what I specified below, but ibm-prtm package needs to depend on OpenIPMI too.  This is the package that provides /etc/init.d/ipmi which loads the ipmi drivers needed by ipmitool to talk to the BMC.

Also, I am not sure how this works, but we need to make sure that the ipmi init script is enabled too.  I thought that is what the LSB headers of Requires and Provides are supposed to do, but apparently not.  So we need to add a 'chkconfig ipmi on' to the post-install script or something.

So to sum up:
1) add rpm dependency for OpenIPMI package
2) enable ipmi init script on install
Comment 4 Florian Nadge 2010-08-04 09:42:46 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
Support added for SMI remediation for the IBM BladeCenter HS22V, IBM System x3650 M3 and x3550 M3 systems. In addition, the init script has been fixed so that it is now compliant with Linux Standard Base (LSB) guidelines, thus resolving this issue.
Comment 8 errata-xmlrpc 2010-08-25 08:59:03 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2010-0654.html

Note You need to log in before you can comment on or make changes to this bug.