Bug 592978 - Change Job detail page to use AJAX for showing results
Change Job detail page to use AJAX for showing results
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.5
All Linux
urgent Severity urgent (vote)
: 0.5.40
: ---
Assigned To: Raymond Mancy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 10:27 EDT by Marian Csontos
Modified: 2015-05-03 21:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-26 13:17:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Csontos 2010-05-17 10:27:44 EDT
Description of problem:
Opening J:640 results in ISE.

Version-Release number of selected component (if applicable):
0.5.35

How reproducible:
100%

Steps to Reproduce:
1. https://beaker.engineering.redhat.com/jobs/640
2.
3.
  
Actual results:
ISE

Expected results:
Display details of the job

Additional info:
Time-stamp: 2010-05-17 14:25 GMT
Comment 1 Bill Peck 2010-05-20 11:19:33 EDT
This no longer produces an ISE 500 due to the proper config changes.

But I'm going to hijack this bug and request a change to the jobs page since even though it does work it doesn't scale. :-)


Ray,

Currently we load all task results for every recipe at display time and hide them with css until someone clicks on either "Show All" or "Show Failures".  This works fine for small jobs but for jobs like 640 it fails miserably.

I'm suggesting we don't load the task results at all and change the buttons "Show All" and "Show Failures" to use ajax calls and those results would display in the div.

Let me know if you have any questions.  I'm raising the priority on this bug since I think this is the most important bug for you to work on right now.  I'd like to shoot for next Wednesday deployment if possible.

Thanks!
Comment 2 Raymond Mancy 2010-05-21 03:37:54 EDT
I've put it up on beaker-devel.bne
It will make an Ajax call for the first time you click on one of the buttons.


http://git.fedorahosted.org/git/?p=beaker.git;a=commit;h=eb1d006188258f05e59c903de6ffe9b14d91a749
Comment 3 Bill Peck 2010-05-21 10:08:02 EDT
Your awesome Ray!

Merged.  will go out in next release.
Comment 4 Bill Peck 2010-05-21 10:55:07 EDT
I found one issue while testing.

If you have a "Show All" or "Show Failed" results open and then click through to see a log then click back it doesn't show the task runs from the ajax call.

I think the logic will need to be moved to the show routines?
Comment 5 Bill Peck 2010-05-21 15:12:45 EDT
Hi Ray,

I didn't get a chance to fix the not loading problem.. but I did fix the following things that I also found wrong. :-)

      - fix ajax call to order tasks correctly when viewing from recipe.
      - turn off pagination when viewing from recipe.
      - Always show logs

Please do a git pull before making any fixes. :-)
Comment 6 Bill Peck 2010-05-21 15:26:57 EDT
Show Failed results doesn't work unless you did "Show All" results first. :-)
Comment 7 Bill Peck 2010-05-21 16:38:45 EDT
Ok, I think its all good now.  I just moved your call into the show_all and show_fail methods.

Will be in next release.

Note You need to log in before you can comment on or make changes to this bug.