Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 592995 - Message propagation with or without "cluster-size" option
Message propagation with or without "cluster-size" option
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
beta
All Linux
low Severity medium
: ---
: ---
Assigned To: messaging-bugs
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 11:00 EDT by ppecka
Modified: 2010-08-30 07:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-30 07:55:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ppecka 2010-05-17 11:00:56 EDT
Description of problem:
regarding of posts under https://bugzilla.redhat.com/show_bug.cgi?id=557243, 
behaviour of clustered qpidd nodes with or without "--cluster-size" option changes appereance/doubling of messages over nodes, but not stated in documentation. 


Version-Release number of selected component (if applicable):
1.3beta

How reproducible:
100%

Steps to Reproduce:
1. run M clustered qpidd instances (for matter of simplicity only two Q1,Q2) WITHOUT option --cluster-size
2. send one batch consisting of N messages to Q1
3. receive ALL messages on Q2
  
Actual results:
on Q2 or Q1 will be M * N messages

Expected results:
on Q2 or Q1 we can read only N messages


Additional info:
this behaviour can be changed when using "--cluster-size" option


Is this behaviour expected?
Comment 1 Gordon Sim 2010-05-17 12:36:21 EDT
Can you give a bit more detail on reproducing this? I started two brokers in the cluster, created a queue, connected to one node and sent 20 messages. connected to the other node and received the same 20 messages as expected. What am I doing wrong or what am I missing out?
Comment 2 ppecka 2010-05-18 04:51:40 EDT
i'm retesting right now, but still not able to reproduce again on 1.3beta
Comment 3 ppecka 2010-05-18 05:54:40 EDT
NOT A BUG

Note You need to log in before you can comment on or make changes to this bug.