Bug 59300 - Weeeird warning output from link stage (might be binutils not gcc)
Weeeird warning output from link stage (might be binutils not gcc)
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-04 15:48 EST by Bill Crawford
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-04 19:36:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2002-02-04 15:48:55 EST
Description of Problem:
Not sure if this should actually be a binutils bug, but when trying to build
xpaint (is this why it disappeared from Raw Hide?):

[bill@pikachu xpaint]$ make
making always in ./rw...
make[1]: Entering directory `/home/bill/build/BUILD/xpaint/rw'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/bill/build/BUILD/xpaint/rw'
rm -f xpaint
gcc -o xpaint -O2 -march=i386 -mcpu=i686 -pipe      -L/usr/X11R6/lib chroma.o
color.o colorEdit.o cutCopyPaste.o dialog.o fatBitsEdit.o         fileName.o
fontSelect.o grab.o snapshot.o graphic.o hash.o help.o       image.o imageComp.o
iprocess.o main.o menu.o misc.o     operation.o palette.o pattern.o protocol.o
readRC.o size.o      text.o texture.o typeConvert.o arcOp.o blobOp.o boxOp.o
brushOp.o circleOp.o fillOp.o   fontOp.o lineOp.o pencilOp.o polyOp.o splineOp.o
selectOp.o     sprayOp.o dynPenOp.o Colormap.o Paint.o PaintEvent.o
PaintRegion.o PaintUndo.o -Lrw -lrw -L/usr/X11R6/lib -lXpm -L/usr/lib -ltiff 
-L/usr/lib -ljpeg -L/usr/lib -lpng -lz   -lXaw -lXmu -lXt -lSM -lICE -lXpm
-lXext -lX11 -lm   
long double restrict: In float    `unsigned __int128':
long double restrict(.unsigned short+0x4b): unsigned shortushortofloat`unsigned
long' intdsigned char, bool   use `unsigned long'

Version-Release number of selected component (if applicable):
[bill@pikachu build]$ rpm -q gcc binutils
gcc-3.1-0.20
binutils-2.11.92.0.12-10
Comment 1 Jakub Jelinek 2002-02-04 19:36:06 EST
This is because of a bogus libiberty/cp-demangle change which was fixed 2 days
ago.
Comment 2 Bill Crawford 2002-02-04 20:09:36 EST
Ah.  Thanks.

Closing then (I'm assuming this will appear in Raw Hide soon :o)

For reference, where's the best place to look (apart from Bugzilla) for stuff
like this?  I really don't have time to read another high-volume mailing list,
and I'm not involved in any way in gcc development; I just want an "executive
summary" ...

Note You need to log in before you can comment on or make changes to this bug.