Bug 593021 - glib-gettextize dies: gettext source directory '/usr/share/glib-2.0/gettext' doesn't exist
Summary: glib-gettextize dies: gettext source directory '/usr/share/glib-2.0/gettext' ...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glib2   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-17 16:00 UTC by Valdis Kletnieks
Modified: 2010-05-19 15:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-19 13:46:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Valdis Kletnieks 2010-05-17 16:00:45 UTC
Description of problem:
Running /usr/bin/glib-gettextize --copy --force results in:

/usr/bin/glib-gettextize: line 139: cd: /usr/share/glib-2.0/gettext: No such file or directory
gettext source directory '/usr/share/glib-2.0/gettext' doesn't exist

And sure enough - neither 'rpm -ql glib-devel', 'repoquery -qf /usr/share/glib-2.0/gettext' can find the directory. Looks like the root cause is on line 55:

gettext_dir=$prefix/share/glib-2.0/gettext

which is apparently pointing someplace somewhere between sketchy and dodgy.


Version-Release number of selected component (if applicable):
glib-devel-1.2.10-33.fc12.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matthias Clasen 2010-05-19 13:46:09 UTC
I fixed this a few days ago.

Comment 2 Valdis Kletnieks 2010-05-19 15:33:30 UTC
Confirming - glib2-devel-2.25.5-2.fc14.x86_64 landed on our local Rawhide mirror last night and fixed the problem, thanks.


Note You need to log in before you can comment on or make changes to this bug.