Bug 593026 - 2.6.34-2.fc14.x86_64 suspicious rcu_dereference_check() usage
2.6.34-2.fc14.x86_64 suspicious rcu_dereference_check() usage
Status: CLOSED DUPLICATE of bug 572520
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 12:11 EDT by Thomas Meyer
Modified: 2010-07-19 11:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-19 11:07:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 16199 None None None Never

  None (edit)
Description Thomas Meyer 2010-05-17 12:11:23 EDT
ACPI: Core revision 20100121
ftrace: converting mcount calls to 0f 1f 44 00 00
ftrace: allocating 20925 entries in 83 pages
Setting APIC routing to flat
..TIMER: vector=0x30 apic1=0 pin1=2 apic2=-1 pin2=-1
CPU0: AMD Athlon(tm) 64 X2 Dual Core Processor 5000+ stepping 02

===================================================
[ INFO: suspicious rcu_dereference_check() usage. ]
---------------------------------------------------
include/linux/cgroup.h:534 invoked rcu_dereference_check() without protection!

other info that might help us debug this:


rcu_scheduler_active = 1, debug_locks = 0
no locks held by watchdog/0/5.

stack backtrace:
Pid: 5, comm: watchdog/0 Not tainted 2.6.34-2.fc14.x86_64 #1
Call Trace:
 [<ffffffff8107bda2>] lockdep_rcu_dereference+0xaa/0xb3
 [<ffffffff8103ec3f>] task_subsys_state+0x4e/0x65
 [<ffffffff810488b4>] __sched_setscheduler+0x1a2/0x305
 [<ffffffff814805a5>] ? schedule+0x5eb/0x653
 [<ffffffff81482e01>] ? _raw_spin_unlock_irqrestore+0x37/0x56
 [<ffffffff810ac37f>] ? watchdog+0x0/0x91
 [<ffffffff81048a3c>] sched_setscheduler+0x13/0x15
 [<ffffffff810ac3ae>] watchdog+0x2f/0x91
 [<ffffffff810ac37f>] ? watchdog+0x0/0x91
 [<ffffffff8106a7c0>] kthread+0x9a/0xa2
 [<ffffffff8107c6ec>] ? trace_hardirqs_on_caller+0x111/0x135
 [<ffffffff8100aae4>] kernel_thread_helper+0x4/0x10
 [<ffffffff81483110>] ? restore_args+0x0/0x30
 [<ffffffff8106a726>] ? kthread+0x0/0xa2
 [<ffffffff8100aae0>] ? kernel_thread_helper+0x0/0x10
lockdep: fixing up alternatives.
Booting Node   0, Processors  #1 Ok.
Brought up 2 CPUs
Total of 2 processors activated (10399.69 BogoMIPS).
sizeof(vma)=176 bytes
sizeof(page)=56 bytes
sizeof(inode)=1168 bytes
sizeof(dentry)=256 bytes
sizeof(ext3inode)=1600 bytes
sizeof(buffer_head)=104 bytes
sizeof(skbuff)=232 bytes
sizeof(task_struct)=9264 bytes
devtmpfs: initialized
Time: 16:04:05  Date: 05/17/10

Bug or feature?
Comment 1 Orion Poplawski 2010-07-19 11:07:42 EDT

*** This bug has been marked as a duplicate of bug 572520 ***

Note You need to log in before you can comment on or make changes to this bug.