Bug 593048 - Intermittent "could not query memory balloon allocation" errors with virt-install
Summary: Intermittent "could not query memory balloon allocation" errors with virt-ins...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt
Version: 5.5
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Daniel Veillard
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-17 17:41 UTC by Steve Reichard
Modified: 2011-01-13 23:12 UTC (History)
10 users (show)

Fixed In Version: libvirt-0.8.2-1.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-13 23:12:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0060 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-01-12 17:22:30 UTC

Description Steve Reichard 2010-05-17 17:41:37 UTC
Description of problem:

During an system build up, a script is called which does a virt install.  Intermittently the virt-install fails with the following output:

Creating domain...                                       |    0 B     00:00     
ERROR    operation failed: could not query memory balloon allocation
ERROR    operation failed: could not query memory balloon allocation
Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 889, in ?
    main()
  File "/usr/sbin/virt-install", line 751, in main
    start_time, guest.start_install)
  File "/usr/sbin/virt-install", line 860, in do_install
    if domain_is_shutdown(None, dom):
  File "/usr/sbin/virt-install", line 791, in domain_is_shutdown
    dominfo = dom.info()
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 523, in info
    if ret is None: raise libvirtError ('virDomainGetInfo() failed', dom=self)
libvirtError: operation failed: could not query memory balloon allocation


The script which perform the install is:
#!/bin/bash
iptables -I RH-Firewall-1-INPUT -s 10.16.136.1 -j ACCEPT
virt-install -n sat-vm -r 8192 --vcpus=4 --cpuset=auto --os-type=linux --os-variant=rhel5.4 --accelerate -w bridge:cloud0 --vnc -l nfs:10.16.136.15:/root/distro --disk path=/dev/MgmtServicesVG/SatVMvol,bus=virtio -x "ks=nfs:10.16.136.15:/root/distro/resources/sat.ks.cfg ip=10.16.136.1 gateway=10.16.143.254 netmask=255.255.248.0" --noautoconsole --wait=-1
service iptables restart




Version-Release number of selected component (if applicable):
 
The host and VM are both unpatched RHEL5.5 systems.

[root@mgmt2 ~]# uname -a
Linux mgmt2.cloud.eng.lab.bos.redhat.com 2.6.18-194.el5 #1 SMP Tue Mar 16 21:52:39 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
[root@mgmt2 ~]# cat /etc/red*rel*
Red Hat Enterprise Linux Server release 5.5 (Tikanga)
[root@mgmt2 ~]# 


[root@mgmt2 ~]# yum list installed libvirt
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Installed Packages
libvirt.i386                                                             0.6.3-33.el5                                                           installed
libvirt.x86_64                                                           0.6.3-33.el5                                                           installed
[root@mgmt2 ~]# 

[root@mgmt2 ~]# yum provides */virt-install
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
python-virtinst-0.400.3-9.el5.noarch : Python modules for starting Xen guest installations
Repo        : installed
Matched from:
Filename    : /usr/bin/virt-install
Filename    : /usr/sbin/virt-install



[root@mgmt2 ~]# 
[root@mgmt2 ~]# yum list installed | grep qemu
This system is not registered with RHN.
RHN support will be disabled.
kvm-qemu-img.x86_64                   83-164.el5                       installed
[root@mgmt2 ~]# 

How reproducible:

Off hand I would say I've seen this repeat between 1/4 to 1/3 of the attempts

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Mark McLoughlin 2010-06-10 14:58:16 UTC
is libvirtd crashing here perhaps? Take a look in /var/log/messages

~/.virtinst/virt-install.log would be helpful too

Comment 2 Daniel Berrangé 2010-06-10 15:09:05 UTC
You wouldn't be getting this error message back if libvirtd had crashed.

This error":

>     if ret is None: raise libvirtError ('virDomainGetInfo() failed', dom=self)
> libvirtError: operation failed: could not query memory balloon allocation

usually means the guest OS has crashed / shutdown unexpectedly.

Run virt-install with the --debug flag and capture that info, and also provide the /var/log/libvirt/qemu/$GUESTNAME.log file

Comment 3 Jiri Denemark 2010-09-02 11:57:52 UTC
Fixed in libvirt-0.8.2-1.el5

Comment 7 weizhang 2010-10-25 08:37:56 UTC
Hi Steve,

I test is on the rhel5.6 with the following steps:
#cat install.sh
#!/bin/bash
virt-install -n test$1 -r 4096 --vcpus=4 --cpuset=auto --os-type=linux --os-variant=rhel5.4 --accelerate -w bridge:br0 --vnc -l http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-5-Server/U5/x86_64/os --disk path=/dev/KVM_Volume/test$1 -x http://home.englab.nay.redhat.com/~nzhang/http/ks-rhel5u5-x86_64.cfg --noautoconsole --wait=-1 &

# for i in $(seq -w -s " " 1 10);do ./install.sh $i;done

# virsh list --all
 Id Name                 State
----------------------------------
 24 test01               running
 25 test02               running
 26 test03               running
 27 test06               running
 28 test05               running
 29 test07               running
 30 test09               running
 31 test04               running
 32 test08               running
 33 test10               running

there is no error. But on the RHEL5.5 release I can not reproduce the steps. I don't know if there is some key point I lost. Could you help me to have a look? Thanks.

My computer info:
# cat /proc/meminfo |grep MemTotal
MemTotal:      8107584 kB
# cat /proc/cpuinfo | grep name | cut -f2 -d: | uniq -c
4  Intel(R) Core(TM)2 Quad CPU    Q9400  @ 2.66GHz

Comment 8 Steve Reichard 2010-10-25 11:31:04 UTC
From what I understand you are not able to run this same procedure on 5.5.  What error are you seeing?

I am not running 5.6 so do not know if the problem is seen there. I know it is still happening on 5.5.  It happened twice on my Friday night.

Comment 10 Min Zhan 2010-10-27 09:11:03 UTC
Verified with Passed in below environments on 3 arches:
-RHEL5.6-Server-x86_64-KVM 
-RHEL5.6-Server-x86_64-Xen
-RHEL5.6-Client-i386-Xen

kernel-xen-2.6.18-228.el5
xen-3.0.3-117.el5
kvm-qemu-img-83-205.el5
kernel-2.6.18-228.el5
libvirt-0.8.2-8.el5

In all these environments above, no error message will display. So please help to confirm if this bug can be turned to verified status. Thanks

Comment 11 Steve Reichard 2010-10-27 13:41:25 UTC
Only used KVM, so I can not make any useful comments regarding Xen

I am not using RHEL5.6. I currently do not plan until it GAs.

Few questions:
 - Is the potential fix (libvirt-0.8.2-1.el5) in RHEL 5.6
 - Did the test that you say pass now, not pass with RHEL5.5
 - Will libvirt-0.8.2-1.el5 be patched into RHEL5.5 - then I could test

Comment 12 Jiri Denemark 2010-10-27 15:22:01 UTC
(In reply to comment #11)
>  - Is the potential fix (libvirt-0.8.2-1.el5) in RHEL 5.6
Yes.

>  - Will libvirt-0.8.2-1.el5 be patched into RHEL5.5 - then I could test
You could try installing just libvirt packages from http://people.redhat.com/jdenemar/libvirt/ They should install just fine on RHEL5.5, although you would probably need --nodeps to avoid the need for installing ebtables package, which is only required for network filters.

Comment 13 Min Zhan 2010-10-28 02:18:53 UTC
(In reply to comment #12)

Then according to comment 10 and comment 12, can this bug turn to be Verified status or need further research? Thanks

Comment 14 Min Zhan 2010-10-29 10:16:48 UTC
Marked as VERIFIED
in the worst case the user (internal Red Hat) can reopen the bug once he updates to 5.6 after GA and if problem persists

Comment 16 errata-xmlrpc 2011-01-13 23:12:26 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0060.html


Note You need to log in before you can comment on or make changes to this bug.