Bug 593090 - Gnucash does not see database backends on 64-bit
Gnucash does not see database backends on 64-bit
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnucash (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 15:36 EDT by Jonathan Corbet
Modified: 2014-03-16 23:23 EDT (History)
2 users (show)

See Also:
Fixed In Version: gnucash-2.3.15-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 13:38:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Corbet 2010-05-17 15:36:54 EDT
Description of problem:

In x86_64 rawhide, gnucash is unable to locate the libdbi backends and thus silently refuses to offer the new database storage options.

Version-Release number of selected component (if applicable):

gnucash-2.3.11-1.fc14.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Ensure that the appropriate libdbi-dbd-* drivers are installed
2. Run gnucash
3. Note that you can neither open or save to anything except "xml."
  
Actual results:

My PostgreSQL server sits there alone, unwanted, and idle.

Expected results:

I should be able to store to postgres.

Additional info:

The problem is the usual /usr/lib64 obnoxiousness - it never ends.  The database drivers are in /usr/lib64, but gnucash wants them in /usr/lib.  Setting GNC_DBD_DIR seems like it should fix it, but it doesn't.  OTOH, doing 
"ln -s /usr/lib64/dbd /usr/lib" makes everything work.
Comment 1 Bill Nottingham 2010-05-18 13:38:40 EDT
Fixed in 2.3.12-3.
Comment 2 Fedora Update System 2010-05-20 09:35:16 EDT
gnucash-2.3.12-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gnucash-2.3.12-3.fc13
Comment 3 Fedora Update System 2010-10-21 00:50:55 EDT
gnucash-2.3.15-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnucash-2.3.15-2.fc13
Comment 4 Fedora Update System 2010-10-30 19:47:50 EDT
gnucash-2.3.15-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.