Bug 5931 - Upgrade hangs if unformatted Linux partition exists
Upgrade hangs if unformatted Linux partition exists
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jay Turner
Depends On:
  Show dependency treegraph
Reported: 1999-10-13 22:29 EDT by fred-m
Modified: 2015-01-07 18:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-10-21 14:11:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description fred-m 1999-10-13 22:29:56 EDT
When I upgraded my RH 6.0 machine with the (awesome)
graphic installer, I had a Linux partition yet unformatted.
When the installer searched for partitions with Red Hat
installed, this partition caused a Python error (visible by
switching the virtual console) and the installer hung.

Formatting that partition with mke2fs solved the problem,
and the upgrade completed smoothly.
Comment 1 Alain RICHARD 1999-10-15 07:11:59 EDT
I have had the same kind of problems with NTFS formated partitions :
mount fails (in my case because there is no NTFS module in the kernel
and in the previouly described case because the ext2 partition is

The mount is tried during the initial localisation of a linux root

This bug is 100% reproductible using either graphic or text installer.

A simple fix for me was to change the partition type from 7
(HPFS/NTFS) to 17 (Hidden HPFS/NTFS) using fdisk, running the
installer/upgrader and changing back the partition
Comment 2 Jay Turner 1999-10-21 14:11:59 EDT
*** This bug has been marked as a duplicate of 5618 ***

Note You need to log in before you can comment on or make changes to this bug.