Bug 593133 - e2fsprogs: upstream fixes - rebase to 1.41.12
e2fsprogs: upstream fixes - rebase to 1.41.12
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Eric Sandeen
BaseOS QE - Apps
: Rebase
: 548787 562936 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 17:52 EDT by Eric Sandeen
Modified: 2010-11-10 15:20 EST (History)
4 users (show)

See Also:
Fixed In Version: e2fsprogs-1.41.12-2.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:20:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of commits since 1.41.10 (4.53 KB, text/plain)
2010-05-18 16:08 EDT, Eric Sandeen
no flags Details

  None (edit)
Description Eric Sandeen 2010-05-17 17:52:06 EDT
A few upstream fixes would be good to get into e2fsprogs pre-beta.

For starters:

e2fsck: mark sparse journal as invalid
e2fsck: make block counting variable in pass1 64 bits
Revert "e2fsck: fix spurious complaints about i_size caused by preallocated blocks"  (rhel6 kernel now has support for this)
Comment 1 RHEL Product and Program Management 2010-05-17 18:05:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Eric Sandeen 2010-05-18 16:06:17 EDT
Looking more closely at the fixes since 1.41.10 (the current version in RHEL6), it's really -all- bugfixes, plus translation updates.

Rather than cherry picking commits, I think it would be best to just rebase at this point, if that's acceptable.

I don't know if I should set flags back to ? ... I'll wait for some response on this.

Thanks,
-Eric
Comment 3 Eric Sandeen 2010-05-18 16:08:15 EDT
Created attachment 414953 [details]
List of commits since 1.41.10
Comment 4 Eric Sandeen 2010-05-18 16:14:14 EDT
Just to be clear about it, I'm going to reset flags to ? to get explicit approval.

Thanks,
-Eric
Comment 5 RHEL Product and Program Management 2010-05-18 16:16:57 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Eric Sandeen 2010-05-18 22:38:25 EDT
Building now.
Comment 7 Eric Sandeen 2010-05-18 22:45:11 EDT
*** Bug 548787 has been marked as a duplicate of this bug. ***
Comment 8 Eric Sandeen 2010-05-19 15:21:52 EDT
There was one thinko in this release that needs to be fixed straight-off, I'm going to just use this bug to fix it without delay.

http://git.kernel.org/?p=fs/ext2/e2fsprogs.git;a=commitdiff;h=ae2272f8459f75c064b2644320db4ec5213d40a9

From: Eric Sandeen <sandeen@redhat.com>
Date: Wed, 19 May 2010 18:20:13 +0000 (-0500)
Subject: e2fsck: correct test for EOFBLOCKS
X-Git-Url: http://git.kernel.org/?p=fs%2Fext2%2Fe2fsprogs.git;a=commitdiff_plain;h=ae2272f8459f75c064b2644320db4ec5213d40a9

e2fsck: correct test for EOFBLOCKS

This test, added to e2fsprogs-1.41.12, is backwards.

If EOFBLOCKS is set, then the size -should- be less than
the last physical block...

xfstests 013 caught this.

Signed-off-by: Eric Sandeen <sandeen@redhat.com>
Signed-off-by: Theodore Ts'o <tytso@mit.edu>
---
Comment 9 Eric Sandeen 2010-05-19 15:27:42 EDT
Built in e2fsprogs-1.41.12-2.el6
Comment 11 Radek Bíba 2010-05-28 05:25:29 EDT
*** Bug 562936 has been marked as a duplicate of this bug. ***
Comment 13 releng-rhel@redhat.com 2010-11-10 15:20:45 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.