Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 593140 - All text replaced by empty squares in Wine
All text replaced by empty squares in Wine
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
12
All Linux
high Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 18:47 EDT by Luke Slater
Modified: 2010-08-05 13:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 13:00:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of fonts being replaced by empty squares. (13.66 KB, image/png)
2010-05-17 18:47 EDT, Luke Slater
no flags Details
stderr of "WINEDEBUG=font winecfg" (51.68 KB, application/x-gzip)
2010-05-19 10:45 EDT, Paul Bolle
no flags Details
"WINEDEBUG=font winecfg 2> font" result (43.04 KB, application/x-gzip)
2010-05-19 13:08 EDT, eric.landaret
no flags Details
This is after winetricks (52.62 KB, application/x-gzip)
2010-05-19 13:22 EDT, eric.landaret
no flags Details

  None (edit)
Description Luke Slater 2010-05-17 18:47:00 EDT
Created attachment 414682 [details]
Example of fonts being replaced by empty squares.

Description of problem:
Wine fonts are replaced by empty boxes in the new release of Wine.

Version-Release number of selected component (if applicable):
1.1.44-3.fc12

How reproducible:
Always

I've tried this on two i686 machines with different hardware, they both showed the issue. If I remove and reinstall all of the involved packages the issue recurs.

Steps to Reproduce:
1. Make sure you're running version 1.1.44-3.fc12 (You might have to enable the testing repo)
2. Start any wine application which doesn't define its own fonts (winecfg exhibits the issue)
  
Actual results:
Characters are replaced by empty boxes, which I take to mean the font can't be found. Shown in the attachment.

Expected results:
Text should show as normal

Additional info:
It seems to have something to do with the fact that in this release of wine, work has gone into splitting the wine fonts up into several packages such as wine-small-fonts for example; the previous release only has a single package called wine-fonts which I presume contains all of them.

Reverting to the previous release fixes the issue.
Comment 1 Andreas Bierfert 2010-05-18 17:06:07 EDT
There are multiple issues at work here.

Do you have the wine meta package installed you did you select the packages by yourself?
Comment 2 Luke Slater 2010-05-18 17:13:35 EDT
I have tried both. The issue originally occurred through a natural update through kpackagekit.
Comment 3 Andreas Bierfert 2010-05-18 17:50:35 EDT
Could you post two things:

'rpm -qa | grep font | sort'

and

'WINEDEBUG=font winecfg 2> font'
Comment 4 Luke Slater 2010-05-18 17:57:00 EDT
lato luke # rpm -qa | grep font | sort
abyssinica-fonts-1.0-5.fc12.noarch
bitmap-fonts-0.3-9.fc12.noarch
cjkuni-uming-fonts-0.2.20080216.1-30.fc12.noarch
dejavu-fonts-common-2.30-2.fc12.noarch
dejavu-sans-fonts-2.30-2.fc12.noarch
dejavu-sans-mono-fonts-2.30-2.fc12.noarch
dejavu-serif-fonts-2.30-2.fc12.noarch
fontconfig-2.8.0-1.fc12.i686
fontpackages-filesystem-1.41-1.fc12.noarch
ghostscript-fonts-5.50-23.fc12.noarch
jomolhari-fonts-0.003-8.fc12.noarch
kacst-art-fonts-2.0-5.fc12.noarch
kacst-book-fonts-2.0-5.fc12.noarch
kacst-decorative-fonts-2.0-5.fc12.noarch
kacst-digital-fonts-2.0-5.fc12.noarch
kacst-farsi-fonts-2.0-5.fc12.noarch
kacst-fonts-common-2.0-5.fc12.noarch
kacst-letter-fonts-2.0-5.fc12.noarch
kacst-naskh-fonts-2.0-5.fc12.noarch
kacst-office-fonts-2.0-5.fc12.noarch
kacst-one-fonts-2.0-5.fc12.noarch
kacst-pen-fonts-2.0-5.fc12.noarch
kacst-poster-fonts-2.0-5.fc12.noarch
kacst-qurn-fonts-2.0-5.fc12.noarch
kacst-screen-fonts-2.0-5.fc12.noarch
kacst-title-fonts-2.0-5.fc12.noarch
kacst-titlel-fonts-2.0-5.fc12.noarch
khmeros-base-fonts-5.0-7.fc12.noarch
khmeros-fonts-common-5.0-7.fc12.noarch
liberation-fonts-common-1.05.1.20090721-2.fc12.noarch
liberation-mono-fonts-1.05.1.20090721-2.fc12.noarch
liberation-sans-fonts-1.05.1.20090721-2.fc12.noarch
liberation-serif-fonts-1.05.1.20090721-2.fc12.noarch
libfontenc-1.0.5-2.fc12.i686
libXfont-1.4.1-1.fc12.i686
lklug-fonts-0.6-1.20090803cvs.fc12.noarch
lohit-assamese-fonts-2.4.3-2.fc12.noarch
lohit-bengali-fonts-2.4.3-3.fc12.noarch
lohit-gujarati-fonts-2.4.4-1.fc12.noarch
lohit-hindi-fonts-2.4.3-3.fc12.noarch
lohit-kannada-fonts-2.4.4-2.fc12.noarch
lohit-maithili-fonts-2.4.3-2.fc12.noarch
lohit-marathi-fonts-2.4.3-2.fc12.noarch
lohit-oriya-fonts-2.4.3-2.fc12.noarch
lohit-punjabi-fonts-2.4.4-1.fc12.noarch
lohit-tamil-fonts-2.4.5-1.fc12.noarch
lohit-telugu-fonts-2.4.5-1.fc12.noarch
paktype-fonts-common-2.0-5.fc12.noarch
paktype-naqsh-fonts-2.0-5.fc12.noarch
paktype-tehreer-fonts-2.0-5.fc12.noarch
smc-fonts-common-04.2-2.fc12.noarch
smc-meera-fonts-04.2-2.fc12.noarch
stix-fonts-0.9-13.fc12.noarch
thai-scalable-fonts-common-0.4.12-2.fc12.noarch
thai-scalable-waree-fonts-0.4.12-2.fc12.noarch
un-core-dotum-fonts-1.0.2-0.11.080608.fc12.noarch
un-core-fonts-common-1.0.2-0.11.080608.fc12.noarch
urw-fonts-2.4-9.fc12.noarch
vlgothic-fonts-20100126-1.fc12.noarch
vlgothic-fonts-common-20100126-1.fc12.noarch
wine-courier-fonts-1.1.44-3.fc12.noarch
wine-fonts-1.1.44-3.fc12.noarch
wine-marlett-fonts-1.1.44-3.fc12.noarch
wine-small-fonts-1.1.44-3.fc12.noarch
wine-symbol-fonts-1.1.44-3.fc12.noarch
wine-system-fonts-1.1.44-3.fc12.noarch
xorg-x11-font-utils-7.2-11.fc12.i686

And I'm not sure what you're asking for in the second one, I run that command but it opens a gui that I can't read because it's all empty boxes. There's no output in the console.
Comment 5 Andreas Bierfert 2010-05-19 02:08:43 EDT
It creates a file 'font' in the directory from which you execute the command. The file contains the needed output so just attach it here (maybe zipped).
Comment 6 eric.landaret 2010-05-19 05:44:13 EDT
(In reply to comment #5)
> It creates a file 'font' in the directory from which you execute the command.
> The file contains the needed output so just attach it here (maybe zipped).    

I encountered the same font issue.
I resolved it with winetricks:

./winetricks corefonts
./winetricks tahoma
Comment 7 Paul Bolle 2010-05-19 10:45:45 EDT
Created attachment 415145 [details]
stderr of "WINEDEBUG=font winecfg"

(In reply to comment #5)
> It creates a file 'font' in the directory from which you execute the command.
> The file contains the needed output so just attach it here (maybe zipped).    

Over 20K lines of debug output created with winecfg from wine-common-1.1.44-4.fc14.noarch is now attached.
Comment 8 Paul Bolle 2010-05-19 10:52:16 EDT
(In reply to comment #6)
> I encountered the same font issue.
> I resolved it with winetricks:
> 
> ./winetricks corefonts
> ./winetricks tahoma    

Perhaps running "WINEDEBUG=font winecfg 2> font" on your system, gzipping the file "font", and attaching that here, might help in pinpointing this problem (as that will show the debug output for a case where fonts are correctly detected).
Comment 9 eric.landaret 2010-05-19 13:08:06 EDT
Created attachment 415196 [details]
"WINEDEBUG=font winecfg 2> font" result
Comment 10 eric.landaret 2010-05-19 13:12:10 EDT
It was before winetricks ! Here is after winetricks.
Comment 11 eric.landaret 2010-05-19 13:22:03 EDT
Created attachment 415206 [details]
This is after winetricks
Comment 12 Andreas Bierfert 2010-05-19 15:27:20 EDT
Thanks for submitting the needed information. I am sure as to what is causing these problems now. I will see if I can get it fixed.
Comment 13 Paul Bolle 2010-08-04 18:18:17 EDT
(In reply to comment #12)
> I will see if I can get it fixed.    

Looks fixed in wine-*-1.2.0-2.fc15.*
Comment 14 eric.landaret 2010-08-05 03:36:43 EDT
It is fixed for me since the first release candidate of wine 1.2.0.

Wine 1.2.0 (stable release) and 1.3.0 (development release) have this font issue fixed in Fedora 13.
Comment 15 Andreas Bierfert 2010-08-05 13:00:19 EDT
Thanks for the feedback.

Note You need to log in before you can comment on or make changes to this bug.