Bug 593150 - xinput fails with BadAtom when listing properties on 64 bit
Summary: xinput fails with BadAtom when listing properties on 64 bit
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-apps
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Peter Hutterer
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 00:40 UTC by Peter Hutterer
Modified: 2010-07-02 19:57 UTC (History)
1 user (show)

Fixed In Version: xorg-x11-apps-7.4-10.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-02 19:57:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
upstream patch (1.81 KB, patch)
2010-05-18 10:15 UTC, Matěj Cepl
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 27657 None None None Never

Description Peter Hutterer 2010-05-18 00:40:17 UTC
Description of problem:
xinput --list-props <device> fails with BadAtom on 64 bit machines due to an invalid memory access. The size of properties is different on 32/64 bit, hence the read goes past the memory boundary

Upstream bug: https://bugs.freedesktop.org/show_bug.cgi?id=27657, already committed, can be back-ported easily.

Version-Release number of selected component (if applicable):
xorg-x11-apps-7.4-9.el6

How reproducible:
xinput --list-props "<device id or name>"

In my case it failed on Wacom devices, not on my USB mouse (probably due to the number of atoms being different on the two)

Comment 1 RHEL Program Management 2010-05-18 00:45:16 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Matěj Cepl 2010-05-18 10:15:13 UTC
Created attachment 414796 [details]
upstream patch

Comment 4 Peter Hutterer 2010-05-19 00:50:53 UTC
MODIFIED

xorg-x11-apps-7.4-10.el6 is available in brew.

Comment 6 Mark Gordon 2010-06-22 19:36:22 UTC
Fix confirmed, using an intuos3 9x12 that had previously exposed the bug.

-> VERIFIED

Comment 7 releng-rhel@redhat.com 2010-07-02 19:57:48 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.