Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 593160 - logrotate uses wrong file name format, logs are lost
logrotate uses wrong file name format, logs are lost
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 22:16 EDT by William Estrada
Modified: 2010-05-18 08:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 08:22:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of logrotate (2.10 KB, text/plain)
2010-05-17 22:16 EDT, William Estrada
no flags Details

  None (edit)
Description William Estrada 2010-05-17 22:16:20 EDT
Created attachment 414706 [details]
output of logrotate

Description of problem:
Logrotate uses wrong logname format

Version-Release number of selected component (if applicable):


How reproducible:
use logrotate

Steps to Reproduce:
1.logrotate /etc/logrotate.d/httpd
2.
3.
  
Actual results:
He tries to rotate log.0,log.1,log.2,etc.

Old logs are lost


Expected results:
SHoud use log-yyyymmdd format


Additional info:
Comment 1 Daniel Novotny 2010-05-18 08:04:38 EDT
$ rpm -qf /etc/logrotate.d/httpd 
httpd-2.2.14-1.fc12.i686

=> reassigning to httpd
Comment 2 Tomas Smetana 2010-05-18 08:18:40 EDT
The "dateext" (yyyymmdd) suffix format is configured in the /etc/logrotate.conf file before the application specific configurations in /etc/logrotate.d directory are being processed.  Therefore if the user runs 'logrotate -f /etc/logrotate.d/httpd' the system-wide settings are not read and the old log format is being used because it's the hard-coded default.

I wouldn't consider this to be a bug at all.
Comment 3 Joe Orton 2010-05-18 08:22:47 EDT
I agree with Tomas.

Note You need to log in before you can comment on or make changes to this bug.