Bug 593172 - DOCS: virsh manpage lacks information about pool- options.
DOCS: virsh manpage lacks information about pool- options.
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 00:21 EDT by Jo-Erlend Schinstad
Modified: 2012-04-18 17:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 17:10:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jo-Erlend Schinstad 2010-05-18 00:21:24 EDT
Description of problem:
If you try man virsh to look for things related to the storage pools, then you'll discover that those options aren't mentioned at all. 

Since this is a fairly important part of virsh and the manpage doesn't cover it, other things might be missing. It would be nice if someone who knows virsh very well took a look at it and uncovered anything else that might be missing.
Comment 1 Kamil Páral 2010-07-08 07:14:29 EDT
I second this request, pool-* commands are missing from the virsh manpage.
Comment 2 Eric Blake 2012-04-18 17:10:15 EDT
Fixed starting in 0.8.0 with:
commit 9f337ef7525e44d32afaef5f650ede2d07a482b2
Author: Eric Blake <eblake@redhat.com>
Date:   Mon Apr 5 17:21:02 2010 -0600

    virsh: improve documentation
    
    Document several missing commands.  There's more work that could be
    done, but incremental improvements is better than no patch at all.
    
    * tools/virsh.pod (autostart, connect): Improve grammar.
    (create): Improve example.
    (domjobabort, domjobinfo, domxml-from-native, domxml-to-native):
    Document.
    (storage pool commands): New section.

Note You need to log in before you can comment on or make changes to this bug.