Bug 59320 - slow name resolution when not using long DNS name.
slow name resolution when not using long DNS name.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-05 06:39 EST by The Lord Voodoo
Modified: 2016-11-24 09:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 05:50:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description The Lord Voodoo 2002-02-05 06:39:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20020104

Description of problem:
This is bug was already submitted but was closed with NOT A BUG result.
I think this is a BUG. Adding names and alias to /etc/hosts doesn't solve the
problem. The local domain is not appended to the hostname. AND THIS IS THE
STANDARD NAME RESOLUTION PROCEDURE.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try to connect to a xyz.mydomain.* with short name xyz.
2.
3.
	

Actual Results:  Slow name resolution. From 15 to 60 seconds.

Expected Results:  Fast name resolution.

Additional info:

telnet-0.17-20 binaries.

Try to be professional.
Comment 1 Harald Hoyer 2002-02-05 06:57:05 EST
This is a glibc bug...
hints.ai_family = PF_UNSPEC;
getaddrinfo(hostp, portp, &hints, &res0);
with AF_INET this works without delays...

Comment 2 ed.moses 2002-06-05 15:21:42 EDT
I am experiencing a similar problem with slow name resolution.  The system is
RedHat Linux 7.3.  Providing a fqdn results in instant name resolution, using
only a host without the domain portion takes upwards of 30 seconds.

Our RedHat Linux 7.2 systems are not experiencing this problem.

/etc/resolv.conf contains the appropriate entries for name servers and domain.
/etc/nsswitch.conf specifies hosts: dns files

Comment 3 Ulrich Drepper 2003-04-24 01:39:53 EDT
Try a recent release.  I don't think there are any such problems left.
Comment 4 Ulrich Drepper 2003-10-03 05:50:49 EDT
No reply in almost 6 months.  Closing it a fixed in the current code.

If there are applications showing this problem file bugs with the applications
since they are not using getaddrinfo correctly.

Note You need to log in before you can comment on or make changes to this bug.