Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 593203 - Missing file in /usr/share/gdal
Missing file in /usr/share/gdal
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdal (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Balint Cristian
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 03:25 EDT by nabil.servais
Modified: 2010-07-08 19:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 19:02:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nabil.servais 2010-05-18 03:25:29 EDT
Hello,

I can't use transformation projection (wgs84 to Google mercator) with geodjango on fedora 12 x86_64 (it works with debian, ubuntu and mac os X). 
Geodjango use gdal projection, this projection are defined in /usr/share/gdal.
In fedora we have : 

total 1.3M
drwxr-xr-x.   2 root root 4.0K 2010-05-18 08:54 .
drwxr-xr-x. 262 root root  12K 2010-05-18 08:54 ..
-rw-r--r--.   1 root root 6.7K 2009-08-22 12:20 coordinate_axis.csv
-rw-r--r--.   1 root root  13K 2009-08-22 12:20 ellipsoid.csv
-rw-r--r--.   1 root root  39K 2009-08-22 12:20 gcs.csv
-rw-r--r--.   1 root root 1.5K 2009-08-22 12:20 gcs.override.csv
-rw-r--r--.   1 root root  10K 2009-08-22 12:20 gdal
-rw-r--r--.   1 root root 153K 2009-08-22 12:20 gdal_datum.csv
-rw-r--r--.   1 root root 2.0K 2009-08-22 12:20 gdalicon.png
-rw-r--r--.   1 root root  13K 2009-08-22 12:20 GDALLogoBW.svg
-rw-r--r--.   1 root root  13K 2009-08-22 12:20 GDALLogoColor.svg
-rw-r--r--.   1 root root  13K 2009-08-22 12:20 GDALLogoGS.svg
-rw-r--r--.   1 root root  16K 2009-08-22 12:20 gt_datum.csv
-rw-r--r--.   1 root root 1.7K 2009-08-22 12:20 gt_ellips.csv
-rw-r--r--.   1 root root 481K 2009-08-22 12:20 pcs.csv
-rw-r--r--.   1 root root  921 2009-08-22 12:20 pcs.override.csv
-rw-r--r--.   1 root root 1.6K 2009-08-22 12:20 prime_meridian.csv
-rw-r--r--.   1 root root 178K 2009-08-22 12:20 projop_wparm.csv
-rw-r--r--.   1 root root  13K 2009-08-22 12:20 s57agencies.csv
-rw-r--r--.   1 root root  18K 2009-08-22 12:20 s57attributes_aml.csv
-rw-r--r--.   1 root root 7.1K 2009-08-22 12:20 s57attributes.csv
-rw-r--r--.   1 root root 8.6K 2009-08-22 12:20 s57attributes_iw.csv
-rw-r--r--.   1 root root  21K 2009-08-22 12:20 s57expectedinput.csv
-rw-r--r--.   1 root root  63K 2009-08-22 12:20 s57objectclasses_aml.csv
-rw-r--r--.   1 root root  31K 2009-08-22 12:20 s57objectclasses.csv
-rw-r--r--.   1 root root  37K 2009-08-22 12:20 s57objectclasses_iw.csv
-rw-r--r--.   1 root root 9.0K 2009-08-22 12:20 seed_2d.dgn
-rw-r--r--.   1 root root 2.0K 2009-08-22 12:20 seed_3d.dgn
-rw-r--r--.   1 root root  11K 2009-08-22 12:20 stateplane.csv
-rw-r--r--.   1 root root  19K 2009-08-22 12:20 unit_of_measure.csv

And in the gdal source (for the version 1.6.3) :

total 1792
-rw-r--r--. 1 nabil nabil   6797 2008-07-21 21:20 coordinate_axis.csv
-rw-r--r--. 1 nabil nabil  11977 2007-09-28 22:52 cubewerx_extra.wkt
-rw-r--r--. 1 nabil nabil 345646 2007-03-19 03:44 ecw_cs.wkt
-rw-r--r--. 1 nabil nabil  12848 2008-07-21 21:20 ellipsoid.csv
-rw-r--r--. 1 nabil nabil     50 2004-03-04 19:06 epsg.wkt
-rw-r--r--. 1 nabil nabil 206041 2009-07-29 04:46 esri_extra.wkt
-rw-r--r--. 1 nabil nabil  39191 2008-07-21 21:20 gcs.csv
-rw-r--r--. 1 nabil nabil   1454 2008-10-30 19:31 gcs.override.csv
-rw-r--r--. 1 nabil nabil 155975 2007-07-20 22:21 gdal_datum.csv
-rw-r--r--. 1 nabil nabil   2037 2006-10-05 03:54 gdalicon.png
-rw-r--r--. 1 nabil nabil  13084 2006-10-05 03:55 GDALLogoBW.svg
-rw-r--r--. 1 nabil nabil  12367 2006-10-05 03:55 GDALLogoColor.svg
-rw-r--r--. 1 nabil nabil  12367 2006-10-05 03:55 GDALLogoGS.svg
-rw-r--r--. 1 nabil nabil  15804 2007-10-23 03:03 gt_datum.csv
-rw-r--r--. 1 nabil nabil   1719 2007-10-23 03:03 gt_ellips.csv
-rw-r--r--. 1 nabil nabil 492362 2008-07-21 21:20 pcs.csv
-rw-r--r--. 1 nabil nabil    921 2007-07-20 22:21 pcs.override.csv
-rw-r--r--. 1 nabil nabil   1599 2002-11-28 16:53 prime_meridian.csv
-rw-r--r--. 1 nabil nabil 181552 2008-07-21 21:20 projop_wparm.csv
-rw-r--r--. 1 nabil nabil  13304 2006-02-15 21:22 s57agencies.csv
-rw-r--r--. 1 nabil nabil  18115 2005-07-30 20:27 s57attributes_aml.csv
-rw-r--r--. 1 nabil nabil   7254 2000-08-29 20:04 s57attributes.csv
-rw-r--r--. 1 nabil nabil   8745 2005-08-30 20:02 s57attributes_iw.csv
-rw-r--r--. 1 nabil nabil  20885 2000-08-29 20:04 s57expectedinput.csv
-rw-r--r--. 1 nabil nabil  63984 2007-11-20 15:40 s57objectclasses_aml.csv
-rw-r--r--. 1 nabil nabil  31226 2007-11-20 15:40 s57objectclasses.csv
-rw-r--r--. 1 nabil nabil  37030 2007-11-20 15:40 s57objectclasses_iw.csv
-rw-r--r--. 1 nabil nabil   9216 2002-11-12 19:36 seed_2d.dgn
-rw-r--r--. 1 nabil nabil   2048 2003-05-12 16:42 seed_3d.dgn
-rw-r--r--. 1 nabil nabil  10315 2008-07-21 21:20 stateplane.csv
-rw-r--r--. 1 nabil nabil  18860 2008-07-21 21:20 unit_of_measure.csv

You forget the wkt definition in the rpm package (or they aren't in gdal 1.6.1). I will build by myself gdal in waiting of a solution.
Comment 1 nabil.servais 2010-05-18 08:20:17 EDT
With gdal compiled from scratch, it works perfectly.
Comment 2 Volker Fröhlich 2010-07-08 18:55:38 EDT
Fedora uses a special tarball where some things are stripped out for license reasons:

Removed files:
========================================
# due to uncertain license issues
and derivative copy from ESRI (TM) and CubeWerx (TM):

data/cubewerx_extra.wkt
data/esri_extra.wkt
data/epsg.wkt <- removed paths.
data/ecw_cs.wkt <- removed paths.

Removed folders plus its contents:
========================================
# due to uncertain license issues these formats
are removed and not suported in fedora pack:

swig/php <-- PHP license, incompatible mixture.

Note You need to log in before you can comment on or make changes to this bug.