Bug 593207 - SELinux is preventing /usr/bin/gcm-apply "write" access on /var/run/cups/cups.sock.
SELinux is preventing /usr/bin/gcm-apply "write" access on /var/run/cups...
Status: CLOSED DUPLICATE of bug 588295
Product: Fedora
Classification: Fedora
Component: gnome-color-manager (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:cc5b35163bb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 03:44 EDT by leigh scott
Modified: 2010-09-25 11:44 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 08:47:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description leigh scott 2010-05-18 03:44:53 EDT
Summary:

SELinux is preventing /usr/bin/gcm-apply "write" access on
/var/run/cups/cups.sock.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gcm-apply. It is not expected that this
access is required by gcm-apply and this access may signal an intrusion attempt.
It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:cupsd_var_run_t:s0
Target Objects                /var/run/cups/cups.sock [ sock_file ]
Source                        gcm-apply
Source Path                   /usr/bin/gcm-apply
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gnome-color-manager-2.30.1-2.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-13.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.33.4-95.fc13.x86_64 #1 SMP Thu May 13 05:16:23
                              UTC 2010 x86_64 x86_64
Alert Count                   13
First Seen                    Wed 07 Apr 2010 15:23:45 BST
Last Seen                     Tue 18 May 2010 08:28:52 BST
Local ID                      0a672658-ff51-42e3-afa9-42152e1a77f1
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274167732.271:8): avc:  denied  { write } for  pid=2081 comm="gcm-apply" name="cups.sock" dev=sdd3 ino=310212 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cupsd_var_run_t:s0 tclass=sock_file

node=(removed) type=AVC msg=audit(1274167732.271:8): avc:  denied  { connectto } for  pid=2081 comm="gcm-apply" path="/var/run/cups/cups.sock" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tclass=unix_stream_socket

node=(removed) type=SYSCALL msg=audit(1274167732.271:8): arch=c000003e syscall=42 success=yes exit=4294967424 a0=f a1=244a7b8 a2=1a a3=7fff65a53f04 items=0 ppid=1 pid=2081 auid=4294967295 uid=42 gid=477 euid=42 suid=42 fsuid=42 egid=477 sgid=477 fsgid=477 tty=(none) ses=4294967295 comm="gcm-apply" exe="/usr/bin/gcm-apply" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gcm-apply,xdm_t,cupsd_var_run_t,sock_file,write
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t cupsd_t:unix_stream_socket connectto;
allow xdm_t cupsd_var_run_t:sock_file write;
Comment 1 Daniel Walsh 2010-05-18 08:47:15 EDT

*** This bug has been marked as a duplicate of bug 588295 ***

Note You need to log in before you can comment on or make changes to this bug.