Bug 59322 - freetype doesnt compile
freetype doesnt compile
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: freetype (Show other bugs)
1.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-05 06:41 EST by josef radinger
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-06 08:00:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description josef radinger 2002-02-05 06:41:53 EST
Description of problem:
g++ -Wall -pedantic -I../freetype-pre1.4/lib/. -ggdb -c parser.cpp     -fPIC -DPIC
parser.cpp:1501: declaration of `int isatty (int)' throws different 
exceptions
/usr/include/unistd.h:668: than previous declaration `int isatty (int) 
throw ()'
parser.cpp:1280: warning: `void yyunput (int, char *)' defined but not used


Version-Release number of selected component (if applicable):
2.0.6
but 2.0.5 didnt compile either

How reproducible:
Always

Steps to Reproduce:
1.rpm --rebuild --target i686 freetype-2.0.6.src.rpm


Additional info:

removing the code-section around line 1501 solved the problem for me, but i'm
not to sure if its ok (i didnt use ttmkfdir)
Comment 1 Mike A. Harris 2002-02-05 12:16:25 EST
I just ran: rpm --rebuild --target=i686 freetype-2.0.6-2.src.rpm

And I ended up with:
pts/18 mharris@devel:~/rpmbuild/SRPMS$ dir ../RPMS/freetype-*.i686.rpm
-rw-rw----    1 mharris    546946 Feb  5 12:09 ../RPMS/freetype-2.0.6-2.i686.rpm
-rw-rw----    1 mharris      9115 Feb  5 12:09
../RPMS/freetype-demos-2.0.6-2.i686.rpm
-rw-rw----    1 mharris    420236 Feb  5 12:09
../RPMS/freetype-devel-2.0.6-2.i686.rpm
-rw-rw----    1 mharris     19521 Feb  5 12:09
../RPMS/freetype-utils-2.0.6-2.i686.rpm

Can you provide more details?  What specific compiler, and whatnot?
Be as detailed as possible.


Comment 2 josef radinger 2002-02-06 06:14:37 EST
here's some more info (dont know if all is needed :)
gcc-2.96-98
gcc-objc-2.96-98
kgcc-1.1.2-40
gcc-c++-2.96-98
gcc-g77-2.96-98
byacc-1.9-16
rpm-4.0.4-0.11

could it be that gcc-2.96-98 breaks freetype (on a second machine with the same
gcc, freetype doesnt compile, too).

i could provide shell access (ssh) to one machine, if needed.
yours josef
Comment 3 josef radinger 2002-02-06 07:47:40 EST
now it works for me (at least on one machine, will have to test on the second
one). just updated some gnome-related packages, and now it works. very mysterious.

will come back, if the second machine has the problem.
joe
Comment 4 josef radinger 2002-02-06 08:00:17 EST
hmm
2.0.6-3 has compile ttmkfdir2 not on by default -> works for me, as log i dont
set it on.
2.0.6-1 has the same error (as it compiles ttmkfdir2 by default)

both machines cannot compile ttmkfdir2
Comment 5 Mike A. Harris 2002-02-09 14:49:19 EST
ttmkfdir2 is purposefully not built.  It is disabled in
the freetype specfile.  This is not a bug, it is intentional.
ttmkfdir is now part of the XFree86 rpm package.  You should
however be able to re-enable ttmkfdir in the freetype package
as it wasn't removed, just disabled.

Note You need to log in before you can comment on or make changes to this bug.