Bug 593240 - sometimes mock hang in setup phase
Summary: sometimes mock hang in setup phase
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mock
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 09:46 UTC by Levente Farkas
Modified: 2013-01-10 05:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-17 10:10:51 UTC
Type: ---


Attachments (Terms of Use)

Description Levente Farkas 2010-05-18 09:46:38 UTC
when i try to build rhel/centos-5 rpm on centos-5 host with 
mock-1.0.7-1.el5.noarch from epel then some srpm (and the same srpms always do the same thing) hang in the:
State Changed: setup
during this there is no cpu, no io load on the build system. there is no network activity and the load is 0.0. this package eg: 
libcmpiutil-0.5.1-1.el5.src.rpm
is there any tip about it?

Comment 1 Levente Farkas 2010-05-18 10:52:38 UTC
another example package: sblim-1-40.el5.src.rpm

Comment 2 Clark Williams 2010-09-10 17:26:22 UTC
What output do you get when you add the -v option to the mock command line?
(and what command line are you using?)

Comment 3 Levente Farkas 2010-09-11 11:08:27 UTC
it's mo longer happened with 1.1.1 (although sblim-1-40.el5.src.rpm still not build)

Comment 4 Clark Williams 2010-09-11 14:38:01 UTC
Would you attach a link to your sblim-1-40.el5.src.rpm to the BZ? I'd like to try and see if it's a mock issue or something else.

Comment 6 Clark Williams 2011-05-06 19:41:25 UTC
I have a modified version of mock that does an os.setsid() in the chroot to start a new session and get rid of the controlling terminal. 

I just tried building your sblim package and it failed with this error:

DEBUG: Binary file /var/tmp/sblim-1-40.el5-root-mockbuild/usr/lib/debug/usr/lib64/libRaToolsDns.so.0.0.0.debug matches
DEBUG: Found '/var/tmp/sblim-1-40.el5-root-mockbuild' in installed files; aborting
DEBUG: RPM build errors:
DEBUG: error: Bad exit status from /var/tmp/rpm-tmp.25019 (%install)
DEBUG:     Bad exit status from /var/tmp/rpm-tmp.25019 (%install)
DEBUG: Child returncode was: 1
INFO: EXCEPTION: Command failed. See logs for output.

That was at the very end of the rpmbuild process. Is this the failure you're seeing?

Comment 7 Levente Farkas 2011-05-21 20:27:32 UTC
this is s result of another mock bug #695298 but it was fixed in 1.1.10. which version did you try?

Comment 8 Clark Williams 2011-05-22 15:20:45 UTC
It was a pre-release version of 1.1.10/1.0.17. Let me try again with my current tree

Comment 9 Clark Williams 2011-05-23 15:41:38 UTC
I just rebuilt sblim-1-40.el5.src.rpm on a RHEL5 system using mock-1.0.17. No hang observed.

Comment 10 Clark Williams 2011-08-17 00:51:13 UTC
Are you still seeing a hang with 1.1.12?

Comment 11 Levente Farkas 2011-08-17 10:10:51 UTC
no longer:-)


Note You need to log in before you can comment on or make changes to this bug.