Bug 593309 - RHEL6 docs: Add information on minimal platform installation via kickstart
Summary: RHEL6 docs: Add information on minimal platform installation via kickstart
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Installation_Guide   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ruediger Landmann
QA Contact:
URL:
Whiteboard:
Keywords: Documentation
: 548248 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 13:42 UTC by Miroslav Vadkerti
Modified: 2012-07-26 13:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 15:33:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 743620 None None None Never

Internal Trackers: 743620

Description Miroslav Vadkerti 2010-05-18 13:42:26 UTC
Description of problem:
When installing minimal platform via kickstart file it has to include:
%packages --nobase
This should be documented for RHEL6.

Sample kickstart file used for testing minimal platform:
http://nest.test.redhat.com/mnt/qa/scratch/mvadkert/minimal_platform/minimal_platform-1.0.ks

More info on mimal platform here:
https://bu-platform.devel.redhat.com/PMRHEL6/rhel6/features/packaging-and-distribution/minimal-package-install

Comment 2 Miroslav Vadkerti 2010-05-18 13:44:52 UTC
As minaml platform is a blocker feature, proposed blocker flag

Comment 3 RHEL Product and Program Management 2010-05-18 13:55:26 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Ryan Lerch 2010-05-18 21:22:23 UTC
Component changed to the Installation Guide.

Comment 5 Miroslav Vadkerti 2010-05-20 19:54:25 UTC
Please see also the issue about add-on repos what need s to be properly documented:

https://bugzilla.redhat.com/show_bug.cgi?id=561164#c82

Comment 6 Ruediger Landmann 2010-06-22 00:36:34 UTC
*** Bug 548248 has been marked as a duplicate of this bug. ***

Comment 7 Ruediger Landmann 2010-06-23 06:41:44 UTC
Description of minimal installation expanded in "9.17. Package Group Selection" in build 0-67 onwards:

"Minimal
    This option provides only the packages essential to run Red Hat Enterprise Linux. A minimal installation provides the basis for a single-purpose server or desktop appliance and maximizes performance and security on such an installation."

Also use of --nobase now refers to minimal installation by name in "32.5. Package Selection":

"--nobase
    Do not install the @Base group. Use this option to perform a minimal installation, for example, for a single-purpose server or desktop appliance."

I still need to document add-on repos.

Comment 8 Ruediger Landmann 2010-06-24 01:36:55 UTC
Adding repos documented in build 0-68 -- "9.17.1. Installing from Additional Repositories"

Comment 9 Miroslav Vadkerti 2010-06-24 05:01:10 UTC
Where can I find the latest build of Installation Docs please?

Comment 11 Miroslav Vadkerti 2010-06-24 07:32:33 UTC
Thanks, the changes seem OK to me.

Comment 13 releng-rhel@redhat.com 2010-11-11 15:33:48 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.