Bug 593374 - Move libXp, libXmu and mozilla-filesystem from optional to base repository
Summary: Move libXp, libXmu and mozilla-filesystem from optional to base repository
Status: CLOSED DUPLICATE of bug 598983
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Dennis Gregorovic
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 16:38 UTC by Alexander Todorov
Modified: 2010-07-05 11:24 UTC (History)
4 users (show)

Fixed In Version: libXmu-1.0.5-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-05 11:24:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Todorov 2010-05-18 16:38:48 UTC
Description of problem:
Several packages from Supplementary require packages from the optional repository which according to dgregor is a bug. As those packages are proprietary ones and we can't do anything to them (or the deps are indeed correct) I'm requesting that libXp, libXmu and mozilla-filesystem packages be moved to the base repository.

The requires are:

java-1.6.0-ibm-1.6.0.8-1jpp.1.el6.x86_64    Requires: libXp.so.6()(64bit)
java-1.5.0-ibm-1.5.0.11.1-1jpp.1.el6.x86_64 Requires: libXmu.so.6()(64bit)
java-1.5.0-ibm-1.5.0.11.1-1jpp.1.el6.x86_64 Requires: libXp.so.6()(64bit)
java-1.6.0-ibm-plugin-1.6.0.8-1jpp.1.el6.x86_64 Requires: /usr/lib64/mozilla/plugins


Version-Release number of selected component (if applicable):
RHEL6.0-20100512.0/WebServer
RHEL6.0-Supplementary-20100514.0

How reproducible:
Always

Steps to Reproduce:
1. Try to install all supplementary packages with the optional repository disabled.

Comment 2 Bill Nottingham 2010-05-18 17:46:51 UTC
1) something in base should be requiring mozilla-filesystem. CC'ing caillon.
2) ancient crufty no-one-should-use X libs added as optional packages in legacy-x.

Comment 3 Christopher Aillon 2010-05-19 21:32:04 UTC
mozilla-filesystem is required by xulrunner (which is in turn required by firefox).  thunderbird and nspluginwrapper also pull it in

Comment 4 Bill Nottingham 2010-05-19 21:45:56 UTC
So it is, and at least as of snapshot 4, it's in the main tree.

Comment 7 Alexander Todorov 2010-05-25 13:50:29 UTC
Dennis, Bill,
for the WebServer variant in snap #5 all of these packages are in the optional repository. Same goes for few more variants. On all of these variants installing Supplementary packages will fail with broken dependencies if they don't have the optional repository enabled. Moving back to ASSIGNED.

What's the desired behavior here? Should all variants have those packages in the base repo? If not those that have them in optional/ should be documented.

Comment 8 Bill Nottingham 2010-05-25 14:26:40 UTC
Web server does not have GUI groups, by design.

Comment 12 Alexander Todorov 2010-06-19 07:42:23 UTC
This is still an issue with latest Supplementary )0618.) for WebServer.

Comment 13 Jan Stodola 2010-06-21 07:03:11 UTC
The same for RHEL6.0-Supplementary-20100618.0/6/ComputeNode/x86_64

Comment 15 Alexander Todorov 2010-07-05 11:24:44 UTC

*** This bug has been marked as a duplicate of bug 598983 ***


Note You need to log in before you can comment on or make changes to this bug.